Ubuntu 14.04 support

actually its not off topic, its keeping in the lines of virtualmin in 'Ubuntu 14.04 and his findings like every one’s else, its helpful

anyways…any updates this month yet?


Thanks for sharing your findings… don’t worry there’s nothing off-topic about discussing how you got Virtualmin working on Ubuntu 14.04 in this thread :slight_smile:

We thought that support for Ubuntu 14.04 would be available right around it’s release, but we noticed a few things during some testing that pushed it back – the Webmin and Virtualmin packages needed updating to handle some of the new package versions properly.

Our testing of that is going well, and we should have a formal release here very soon!


looking forward to updating my pro virtualbox :slight_smile: i need some bleeding edge stuff etc etc

It’ll be soon, tehface!

I’m going to go bug Joe about packaging up what we have now and pushing it out.

The only thing you mentioned that might be a problem is webalizer support, we hadn’t noticed the issues you pointed out regarding Perl. I don’t think that’ll stop us from pushing this out, but if Webalizer isn’t working properly with that Perl version, we’ll have to decide what to do about that.

Thanks for sharing your findings!


Any idea when support for 14.04 will be ready?

We’ve got a new server on standby, and I refuse to do anything with it until virtualmin is installed! :smiley:



I will be soooo happy when it gets supported.
Really looking forward 14.04 installation

Someone recently noticed an issue where, in Apache 2.4, you can no longer mix options in the Options line, where some use a + or -, and others don’t.

Webmin and Virtualmin currently do that in some cases, and using that syntax will cause Apache to throw a syntax error and not start.

Jamie is fixing that up – once that’s done, he’s going to upload a new Virtualmin package into the repo that we can all use for testing.


If it’s not possible to commit to a firm timescale, any idea when support for 14.04 might be ready?! :wink:

If I had to guess, it would be ready and tested in a month or two.
Maybe later.
They have to test various scenarios.

Well, I hope it’s sooner than a month or two – I’m pinging Joe now to see when we can get the updated Webmin and Virtualmin packages pushed into our repo.

Once that happens, they’ll be available there for anyone who wishes to do some testing, and we’ll formally announce support shortly after we do some testing, as well as after we hear how that works for you guys.


Okay, I know a lot of you folks are eager to see Ubuntu 14.04 support – so this post is for anyone who’d like to do some testing and otherwise try it out!

(please note – this isn’t a formal announcement of official Ubuntu 14.04 support, this is an announcement that anyone who wishes to do some beta testing can try it)

In the repo now are versions of Webmin, Virtualmin, and virtualmin-base that should be working properly with Ubuntu 14.04.

We’re still doing some testing on all that, but if anyone would care to try it out, please feel free!

Grab a new version of the install.sh script, and feel free to run through an install on a freshly installed Ubuntu 14.04 system.

There’s one minor gotcha that we’re aware of – Joe’s script didn’t work properly, and didn’t copy out the new Webmin release to the 64 bit repository. That Webmin release is necessary for support to work properly.

The workaround in the meantime is simple – just grab a copy from here, and install this before running the install.sh:


That should be fixed later today.

If you decide to try an install, let us know how it goes!


We discovered two things that should be occurring, but aren’t, during the installation – you’ll need to manually run these two commands in order for Apache to start properly:

mkdir /var/lib/apache2/fcgid a2enmod slotmem_shm


I tried the install - installed a complete virgin installation of 14.04 then grabbed the webmin package and tried to install with the following result:

root@offshostnew:~# dpkg -i ./webmin_1.683_all.deb
Selecting previously unselected package webmin.
(Reading database … 54239 files and directories currently installed.)
Preparing to unpack ./webmin_1.683_all.deb …
Unpacking webmin (1.683) …
dpkg: dependency problems prevent configuration of webmin:
webmin depends on libnet-ssleay-perl; however:
Package libnet-ssleay-perl is not installed.
webmin depends on libauthen-pam-perl; however:
Package libauthen-pam-perl is not installed.
webmin depends on libio-pty-perl; however:
Package libio-pty-perl is not installed.
webmin depends on apt-show-versions; however:
Package apt-show-versions is not installed.

dpkg: error processing package webmin (–install):
dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-16) …
ureadahead will be reprofiled on next reboot
Errors were encountered while processing:

Any ideas?

I guess perl needs to be installed before webmin

sudo apt-get -f install
worked for me

I’ve tried it but ran into some issues on an updated 14.04 installation

  1. Webmin_1.683_all.deb is changed to:

  2. Dependencies were missing, installed them with:
    sudo apt-get -f install

  3. ran the webmin_1.684_all.deb
    Dpkg -i webmin_1.684_all.deb

  4. ran install-1404.sh script
    It exited on the “Failed to detect operating message”

Output of cat /etc/lsb-release:

sudo apt-get -f install fixed the previous problem

When I ran the configuration check I got the message:

The procmail command in the Postfix configuration does not exist.

To fix this I just ran sudo apt-get install procmail-wrapper

It appears as though it is now installed correctly

sudo apt-get -f install fixed the previous problem

When I ran the configuration check I got the message:

The procmail command in the Postfix configuration does not exist.

To fix this I just ran sudo apt-get install procmail-wrapper

It appears as though it is now installed correctly

Although the server appears to be installed correctly (and I ran the commands mkdir /var/lib/apache2/fcgid
a2enmod slotmem_shm) and restarted apache, whenever I attempt to load a web page, I get a 403 error - this is both with migrated domains to the server as well as a newly created domain.

Ubuntu 14.04 has apache 2.4.7 running on it, and it appears as though the ‘allow from all’ configuration directive for directories in the configuration file has been deprecated and should be replaced with ‘Require all granted’

My apologies to anyone who received a “Can’t detect OS version” error during the last few hours – due to some miscommunication, the Virtualmin OS detection file, and the GPL install.sh script, were accidentally overwritten with the version not including the 14.04 changes.

If you received that error during installation, try re-downloading the installer, and try the installation again.