Ubuntu 14.04 - Failed to Detect OS

Hi guys,

I just tried to install virtualmin GPL on Ubuntu 14.04 (OVH Box, Distribution Kernel - NOT OVH Kernel) and I get an error that OS is not recognised.

Anyone have any ideas

As Below:

Checking for HTTP client…found /usr/bin/curl -s -O
Checking for perl…found /usr/bin/perl
Loading log4sh logging library…
INFO - Started installation log in /root/virtualmin-install.log
INFO - Checking for fully qualified hostname…
INFO - Hostname OK: fully qualified as serv.mydomain.com
INFO - Installing serial number and license key into /etc/virtualmin-license
INFO - Loading OS selection library…
INFO - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded.
INFO - Loading OS list…
INFO - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded.
Failed to detect operating system

lsb_release -a yields:

Distributor ID: Ubuntu
Description: Ubuntu 14.04 LTS
Release: 14.04
Codename: trusty

Many thanks


What is the output of this command:

cat /etc/issue

hi !
I’ve got the same issue !

cat /etc/issue doesn’t give me anything
but i have a line in /etc/issue.net => Ubuntu 14.04 LTS

Identical tot the one above actually:

cat /etc/issue doesn’t give me anything but i have a line in /etc/issue.net => Ubuntu 14.04 LTS

I ended up going with ubuntu 12.04LTS


Hmm, that’s unexpected! So you don’t have a /etc/issue file at all? Or is it just empty?

What you may want to do is make your /etc/issue file the same as /etc/issue.net – it just needs that “Ubuntu 14.04 LTS” line in it. The installer uses that to help it detect the OS.

Once you do that, the installer should be able to continue.

I’m curious though – are you using a VPS, or a dedicated server?


It worked ! Thank you Eric ! As you said earlier I’ve just added the line Ubuntu 14.04 LTS into my empty /etc/issue file.

I’m not on a VPS, I’m on a dedicated.

Full Dedicated:

Xeon 1240 V2, 48GB Ram, 2x2 TB Raid 1

Hmm, I haven’t been able to reproduce what you’re seeing, where a new installation of Ubuntu onto a dedicated server doesn’t generate a /etc/issue file.

Are you by chance able to describe anything about your installation process that might help us determine when that occurs?

What I had done previously during my testing is to perform an installation of the “Server” version of Ubuntu 14.04, and essentially chose what seemed to be the default options.

Do you have any thoughts on the options used during your installation process that may have led to that?



For installation I went via the providers web interface [OVH + Hetzner], logged into their netboot console - selected:

The server also runs in raid1

Ubuntu 14.04 LTS,
Partition Scheme was changed from Default [OVH Listed Below]:

/swap [20GB] / [30GB] /home [Remaining]


/swap [20GB] / [Remaining]

I tried with using both the native distribution kernel and the specific OVH kernel.

Everything is automated so I cant see every process.

You could try grabbing a kimsufi [uses same setup system as the OVH/SYS Servers IIRC] for your testing or just have the script check /etc/issue.net.


Confirm this problem with a dedicated OVH (soyoustart) server.

The /etc/issue file exists but is empty, while the /etc/issue.net file contains the Ubuntu 14.04 LTS text.

Copying the text to /etc/issue resolved the problem.

to confirm I just found same problem as premierhw, also on an OVH box.
same solution works



Same problem for Ubuntu 17.04
Is it ok to do the trick with the issue file and add ubuntu 16.04 to trick the installation?

This is not the same problem, miltiades. 17.04 is not a supported OS, and is not expected to work.

Choose an LTS release of Ubuntu (16.04 is the current LTS release), and it should Just Work.

Thank you for your quick response .