Ubuntu 12.04 support now available!

We are excited to announce that the Virtualmin installer now supports Ubuntu 12.04.

Also, if you are planning to upgrade from an earlier Ubuntu version – you can find upgrade instructions here:


If you have any questions, or run into any problems, feel free to let us know!

no webdav by default
no subversion module, iirc on centos it was by default

quotas not working altho i manualy wrote usrquota,grpquota in fstab, Configcheck still fails with “The module could not find the mount point for your home directories filesystem /home. Quotas editing has been disabled.”

Hmm, are you by chance on a Xen-based VPS? We’ve seen an issue where quotas won’t work if there is no /dev/root setup when using Xen.


Im testing Virtualmin on KVM based VPS at the moment

my fstab records are

/dev/sda / ext4 errors=remount-ro,usrquota,grpquota 0 1
/dev/sdb none swap sw 0 0

Not sure if it was mentioned, but it appears that the dkim-filter package no longer exists in 12.04 and has been replaced with OpenDKIM.

Installing package(s) with command apt-get -y --force-yes -f install dkim-filter .. Reading package lists... Building dependency tree... Reading state information... E: Unable to locate package dkim-filter .. install failed! .. installation failed!


Thanks for the heads up about OpenDKIM – we’re working on updating Webmin/Virtualmin on Ubuntu 12.04 to work properly with that.


I’ve just finished updating Virtualmin’s DKIM support to work with the OpenDKIM package included in Ubuntu 12.04. This fix will be included in the 3.93 Virtualmin release.

I have enabled correctly quotas in a xen virtualized VPS, I did this on the webmin side:

# cat /etc/fstab /dev/xvda1 / ext3 defaults,grpquota,usrquota,noatime 1 0


Kernel quota version: 6.5.1
Number of dquot lookups: 1056465
Number of dquot drops: 1010781
Number of dquot reads: 72
Number of dquot writes: 123
Number of quotafile syncs: 14
Number of dquot cache hits: 1056354
Number of allocated dquots: 72
Number of free dquots: 28
Number of in use dquot entries (user/group): 44

repquota -a | grep test

test2.com – 48 0 0 12 0 0
test2@test2.com – 64 0 0 16 0

Virtualmin seems to have the quotas enabled in the configuration System Settings -> Virtualmin Configuration -> Set quotas for domain and mail users? -> Yes. And plans System Settings-> Account Plans -> Default Plan -> 1025 quota.

But when I edit a mail user, or domain I cannot see anywhere where to edit the quotas for a user. I am looking at Edit User -> Quota and home directory settings?

Is there any module that needs to be installed, how can I debug this further?

Hi guys

I ran Ubuntu 10.04 Lucid to 12.04 Precise Upgrade and all went remarkably well. Only one small problem I am receiving the following email every 10 minutes. I have tried a few thing but nothing has stopped it yet. any suggestions would be much appreciated

Error: SiteDomain parameter not defined in your config/domain file. You must edit it for using this version of AWStats.
Setup (’/etc/awstats/awstats.conf’ file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in ‘docs’ directory).



You may want to edit “/etc/cron.d/awstats”, and comment out the lines you see in there. That should prevent any of those errors.


Hi andreychek

commenting out those lines did stop the email reporting the the error but it did not fix the cause. Isn’t that just a band aid measure, shouldn’t we fix the problem in awstats.conf?

On to an unrelated matter.

In the upgrade instructions is

Reset Dependency Flags

These packages are already installed, but the following command will tell apt not include them anytime “apt-get autoremove” is run:

apt-get install bind9 spamassassin spamc procmail libnet-ssleay-perl libpg-perl libdbd-pg-perl libdbd-mysql-perl quota iptables openssl python mailman subversion ruby irb rdoc ri mysql-server mysql-client mysql-common postgresql postgresql-client awstats webalizer dovecot-common dovecot-imapd dovecot-pop3d proftpd webmin usermin webmin-virtual-server libcrypt-ssleay-perl webmin-virtual-server-theme webmin-virtualmin-dav webmin-virtualmin-svn webmin-virtualmin-awstats webmin-virtualmin-mailman webmin-virtualmin-htpasswd clamav-base clamav-daemon clamav clamav-data clamav-freshclam clamav-docs clamav-testfiles libapache2-mod-fcgid scponly apache2 apache2-doc libapache2-svn libsasl2-2 libsasl2-modules sasl2-bin usermin-virtual-server-theme procmail-wrapper php-pear php5 php5-cgi webmin-security-updates libgd2-xpm

which I ran through Command Shell in the user interface and it looked like it worked, reporting that those packages were already installed.

Today there were a bunch of Package updates so I ran them and that is reporting

Reading package lists…

Building dependency tree…

Reading state information…

The following packages were automatically installed and are no longer required:

pwgen bind9 postgresql-9.1 proftpd-basic libnet-ip-perl db4.8-util libnet-dns-perl re2c clamav bind9utils libnet-xwhois-perl awstats clamav-base subversion libclamav6 apache2 libsvn1 spamc libapache2-mod-fcgid mailman scponly libpg-perl clamav-docs libneon27-gnutls libapache2-svn postgresql postgresql-client-9.1 liberror-perl webalizer ssh libdbd-pg-perl clamav-freshclam libtommath0 libnetaddr-ip-perl libmail-spf-perl clamav-daemon libsys-hostname-long-perl libdigest-hmac-perl spamassassin clamav-testfiles

Use ‘apt-get autoremove’ to remove them.

I thought I would check before removing anything that these are in fact now safe to remove because some are on both lists?

As always
thanks for your invaluable help

Can I please get an answer to the questions above?

I might suggest starting a new thread for new topics – this thread here is getting a little long, and I get confused easily :slight_smile:

A quick answer though – it sounds like you may have performed an upgrade… you may want to take a look at the upgrade instructions (which have been modified since they were originally announced), and look at the section “Reset Dependency Flags”.

If you run the steps there, that should correct a number of packages that shouldn’t be in that list.

The updated instructions are available here:


If you have any questions about that – start a new thread, and we’ll go over your questions there. Thanks!