Ubuntu 10.04 LTS: Failed to detect operating system


I’m trying to install virtualmin using install.sh script, but I get the following error:

... INFO - Loading OS selection library... 2011-06-02 16:31:03 URL:http://software.virtualmin.com/lib/oschooser.pl [4461/4461] -> "oschooser.pl" [1] INFO - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded. INFO - Loading OS list... 2011-06-02 16:31:04 URL:http://software.virtualmin.com/lib/os_list.txt [3170/3170] -> "os_list.txt" [1] INFO - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded. Failed to detect operating system

The contents of the /etc/issue file are:

Ubuntu 10.04.2 LTS \n \l

As far as I know, the Ubuntu version is supported by virtualmin. ¿Am I missing something? ¿Could anyone help me with this, please?

Thanks in adavance!



Yeah, the Virtualmin installer should work well on Ubuntu.

Is that all that’s in your /etc/issue file? And is the content you have there on the first line of the file?


Thanks for your response, Eric.

Yeah! Te only line in my /etc/issue file is that one and it’s the first line. I’ve seen that I also have a /etc/issue.net file with the following content:

Ubuntu 10.04.2 LTS

I guess it shouldn’t affect, but just in case…



The same error: Failed to detect operating system

In my /etc/issue file is ¨Ubuntu 10.04.2 LTS \n \l¨ and in /etc/issue.net is ¨Ubuntu 10.04.2 LTS¨


Okay. I’ll do some digging and get back to you. Thanks for the heads up!


There we go – there was indeed a bug in the os detection, but that should be corrected now.

Give it another shot and let us know if that does the trick for you!




I found a temporary solution of this problem. Install a fresh copy of Ubuntu version 10.04 without an internet connection. After the installation is finished, set the network as appropriate but do not make the required updates. Download it then run install.sh.
After installation is complete you can take the rest of updates.


Perfect Eric!! I run it again and worked well.

Thanks so much!


what about ubuntu 11.04 ? Does virtualmin can run on it ?


The Virtualmin installer only supports the Ubuntu LTS releases. You can see the list of supported OS’s here:



I have run into the same issue. :frowning:

I installed virtualmin gpl today (June 20, 2011) on a fresh copy of Ubuntu Server 10.04.2 LTS and got the following error

[part of the virtualmin-install-log file]
Err http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main subversion 1.6.6dfsg-2ubuntu1.1
404 Not Found [IP: 80]
Get:81 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/universe apache2-suexec-custom 2.2.14-5ubuntu8.4 [96.9kB]
Err http://security.ubuntu.com/ubuntu/ lucid-security/main subversion 1.6.6dfsg-2ubuntu1.1
404 Not Found [IP: 80]
Fetched 43.1MB in 2min 1s (356kB/s)
WARN - 2011-06-20 10:47:48 - apt-get seems to have failed. Are you sure your OS and version is supported?
WARN - 2011-06-20 10:47:48 - http://www.virtualmin.com/os-support
FATAL - 2011-06-20 10:47:48 - Fatal Error Occurred: Installation failed: 0
FATAL - 2011-06-20 10:47:48 - Cannot continue installation.
FATAL - 2011-06-20 10:47:48 - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - 2011-06-20 10:47:48 - re-attempted after any problems have been resolved.
FATAL - 2011-06-20 10:47:48 - Removing temporary directory and files.
FATAL - 2011-06-20 10:47:48 - If you are unsure of what went wrong, you may wish to review the log
FATAL - 2011-06-20 10:47:48 - in /root/virtualmin-install.log

This is a dedicated server and each time i ask them to re-install the OS they charge me $50 :frowning: - this is my second time around as I screwed up before with the root account. It would be good if I can somehow resurrect this install.

Btw this is an aside just to thank you guys for the awesome support. I think virtualmin is truly an amazing piece of sw. I have been using it on many servers for the past few years and it rocks.


The problem the original poster mention should be resolved now… that was an issue with it not being able to detect the OS at all. With your install, it appears to be getting past that point.

In your case, it looks like it wasn’t able to find Subversion and one of the Apache packages in the Ubuntu repository.

First, can you verify that /etc/issue mentions something about Ubuntu 10.04?

Next, what happens if you run this:

apt-get update && apt-get upgrade

Does that work cleanly, or do you see any errors?

Next – I’m curious if you were to try the install again, if it works. It’s possible that it’s an issue with the mirror, and in that case, trying it again may point you to a different mirror.


Hi Eric,

/etc/issue output

Ubuntu 10.04.2 LTS \n \l

/etc/issue.net output

Ubuntu 10.04.2 LTS

I ran the apt-get update && apt-get upgrade and it worked fine

Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Then I ran the installer again and received the same error. (I attached the log file with the hostname edited out)

I ran the installer on a fresh copy of 10.04.2 LTS on a VM machine, but this time I did not do the apt-get update && apt-get upgrade before the virtualmin install and the installation was completed without any errors.

Would it help if I copied the /etc/apt/sources.list file from the VM that installed Virtualmin successfully to the server that it is failing on?

just a thought.

Yeah, the install log is full of errors with apt not being able to find this or that package – all of which should be readily available in the Ubuntu repositories.

You might try that – copying your other sources.list file, and see if that helps.

The goal though would be to make sure it’s using a different mirror. So if that doesn’t work, you can manually edit the file, and change the mirror to something else.


So i copied over the file and ran the virtualmin installer but it did not work :frowning: - same 404 errors for certain packaages.

I know this is more of an Ubuntu forum question, where do I find out what other mirrors would work?

Thank you

Problem Solved! Yay.

I guess the issue was that the Ubuntu Apt-get kept failing on the update. I edited the mirrors and it worked.

Thanks for the help.


The same problem occur in ovh servers trying install Virtualmin on Ubuntu 16.04.01 lts

Have an error during installing Virtualmin: failed to detect operating system.

Any solution?


The same problem occur in ovh servers trying install Virtualmin on Ubuntu 16.04.01 lts

Have an error during installing Virtualmin: failed to detect operating system.

Any solution?

Are you using an OVH template for your Ubuntu install or an ISO from the Ubuntu site?

I have several OVH servers running PROXMOX and the ISO from the Ubuntu site works fine with the current Virtualmin installer.