Trouble switching to hashed passwords


I am running Virtualmin 4.16.gpl on Ubuntu 14.04.2 LTS. After succesfully restoring some domains from backup I would like to switch to hashed passwords (instead of clear-text). I changed the “system settings > default settings > administration user > store clear text passwords?” option to “no, only store hashed passwords”. However after updating the password of a domain admin I am still able to retrieve it clear text in the UI (showpass.cgi). How can i switch to hashed passwords succesfully?


Found a fix. This can be resolved by manually removing the “pass=xx” from the domain file in /etc/webmin/virtual-server/domains.