Trash Folder and Other Folder Errors

I changed the Usermin "Read Mail" module setting to move deleted messages to the Trash folder instead of deleting. After doing so, I got the following message upon attempting to delete a message.

Failed to delete mail : Error in IMAP command UID: Invalid arguments.
I tried to create the folder myself, but got this error.
Missing or invalid folder name
I was testing another mail client and it automatically created a Trash folder, but I tried to delete again and still got to the "Failed to delete..." message. Am I doing something wrong? Is there a way to have the Trash folder created automatically like the Drafts and Sent Mail?<br><br>Post edited by: joeles, at: 2007/10/22 03:32

It turns out that this problem is exhibited anytime I try to move mail from one to another. A copy is created in the destination folder, but the original message is not removed from the source folder. I also get the same UID error as above.

Failed to delete mail : Error in IMAP command UID: Invalid arguments.
I tried changing the delete settings back to "Just delete from mail file" and it deletes as expected. This also causes the error when moving messages to not be displayed, but the message is only copied and not moved as described above.

I’m not sure if it’s related, but if when composing a message, if I “Save as Draft”, then “Edit as New” and try to “Save as Draft” again, I get this message.

Failed to send mail : Cannot modify mail in this type of folder!

Bumping this thread. Has anyone else experienced the same problems?

You need to "purge" the folders first when using IMAP.

Purge deletes any hidden deleted items still in the folders then you can delete the folders.

I have the same problem. New install, current VM Pro, CentOS, no modifications.

I turned off option to save deleted mail and everything works, except now people cannot save deleted mail.

Does this feature work or not work for everyone?

My accounts were originally created on VM GPL/FreeBSD with sendmail. I backed up the accounts and restored them to the new VM Pro/Centos with Postfix. Maybe a transitioned account has something to do with it?

Is there anything in the maillog/mail.log when attempting these actions? The mail client error rarely contains useful information (because the types of errors that they receive are pretty limited).