trac in CentOS 5.8.

trac won’t install properly under VirtualMin on my Centos 5.8 VPS.

Has anybody gotten trac to install under Centos 5.x? I’ve tried every trick I can find on Google, and no dice. If anyone who has done it successful, care to share how you did it?


How are you going about installing it?

And what error messages do you get during that process?


What error messages -aren’t- I getting?

My installation process: went into VirtualMin, created a subdomain, installed trac via the Install Scripts link. Have uninstalled and reinstalled about six times.

So, I tried installing it, and it said I needed svn. So I installed wbm-virtualmin-svn.noarch. Then it wanted Genshi, so I installed Genshi via python-genshi-0.6-2.el5.rf.noarch.rpm. Then postgresql-python.x86_64. Then python-psycopg2.x86_64.

Finally, it popped up, and said svn couldn’t connect due to SQLite. I installed python-sqlite2.x86_64. And then I installed easy_install pysqlite, which resolved the problem.

Now, I get this error:

Traceback (most recent call last):
File “build/bdist.linux-x86_64/egg/trac/web/”, line 440, in send_error
File “build/bdist.linux-x86_64/egg/trac/web/”, line 827, in render_template
File “build/bdist.linux-x86_64/egg/trac/web/”, line 216, in getattr
File “build/bdist.linux-x86_64/egg/trac/web/”, line 300, in _get_session
File “build/bdist.linux-x86_64/egg/trac/web/”, line 198, in init
File “build/bdist.linux-x86_64/egg/trac/web/”, line 219, in get_session
File “build/bdist.linux-x86_64/egg/trac/web/”, line 61, in get_session
File “build/bdist.linux-x86_64/egg/trac/”, line 328, in get_db_cnx
File “build/bdist.linux-x86_64/egg/trac/db/”, line 90, in get_read_db
File “build/bdist.linux-x86_64/egg/trac/db/”, line 152, in get_connection
File “build/bdist.linux-x86_64/egg/trac/db/”, line 226, in get_cnx
File “build/bdist.linux-x86_64/egg/trac/db/”, line 146, in get_cnx
TimeoutError: Unable to get database connection within 0 seconds. (<trac.core.TracError instance at 0xae1b128>)

Basically, as far as I can tell, the issue is with Postgresql. I just installed a fresh trac under a different domain. I had to fix permissions to /home/domainname/tmp so that Apache could read/write from it. And then it said SQLite was unsupported, which led me to believe it wasn’t reading trac.ini, so I gave Apache read/write with the /trac directory and everything in it. And then I got the same error as above.

Which Virtualmin version is it that you’re using there – are you using Pro or GPL?


3.89 Pro.

There is a trac Install Script in Virtualmin Pro – is that by chance what you’re attempting to install, or were you performing the installation manually?


That’s what I’ve been using, yep.

When I try trac-admin from the command line, I get this:

Traceback (most recent call last): File "./trac-admin", line 5, in ? from pkg_resources import load_entry_point File "/usr/lib/python2.4/site-packages/", line 2562, in ? working_set.require(__requires__) File "/usr/lib/python2.4/site-packages/", line 626, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python2.4/site-packages/", line 524, in resolve raise DistributionNotFound(req) # XXX put more info here pkg_resources.DistributionNotFound: Trac==0.12.2

This leads me to believe there’s something wrong with the installation script, as it seems to not be finding trac at all.

Fixed that issue by putting a trac.pth pointing to the path to the trac .egg file in the domain.

And now am back to the Postgresql connection issue, but at the command line, too.

Any ideas?