Total disk space used error.

I have a virtual server that has 226mb of files in it’s home directory. As of a few days ago without any new files or email being added, the the amount grows by several GB a day.

Every time I run “Check Disk Quotas”, it returns to 226mb, however it immediately starts growing from there. What could be causing this issue?



Hmm… how are you checking the size of the directory? Is that something Virtualmin is saying, or are you determining that by a command line tool of some sort?

If you hadn’t checked this already, I’d be curious to see what “du -sh /home/USERNAME” shows.



That you for your reply. I believe you are asking how I know that what the control panel and " quota -g arguify" are incorrectly showing a growingly high amount of space used. I guess mainly because I can sort the home directly by recently changed files and I see there hasn’t been much activity there.

As soon as I run the quota check, it goes back down. In fact I need to run it now, as below should only be showing 226mb and it will after I run the check.

[root@server arguify]# du -sh /home/arguify
4.7G /home/arguify

Boy-oh-boy… I better come clean on this one. Despite my insistence that running the quota checks makes the high disk space go back down, I ran it after my last post and nothing changed (I swear it did yesterday). Today it was 5gb and growing fast.

I discovered it’s the error_log. My client has got something going wrong there that is reporting more errors than I have ever seen before.

I guess I can take it from here. Thanks for making me question my bad conclusion.


Well, there’s different ways to calculate the space being used – whether or not it’s looking at the user’s quota, the group quota, or the actual files themselves.

When you use the “du -sh” there, it’s showing 4.7GB of files… which does seem to suggest a large number of files in your directory.

This shouldn’t matter, but just to verify – does the “du -sh” command output change after you run the quota check?

If not, than the key may just be to determine why “du” is showing 4.7GB of files there.

If you go into /home/arguify, you could run this command:

du -sh *

That will show you all the directories in your home directory, and how much space each is using.


It’s no problem at all – it’s entirely possible that a Quota Check coincided with a log rotate or something, which may have led you to that conclusion.

I’m glad you figured out the cause though!