Tool -> command shell not working

OS type and version Ubuntu Linux 23.04
Webmin version 2.111
OS type and version AlmaLinux 8.9
Webmin version 2.111


I have try the command shell under webmin tool. previously all is working fine which we can run script/command from this shell. but now not working. it kept loading infinite. i have try both ubuntu and almalinux. it could be the bug. cause when i try this command using the ssh/terminal it was working fine

Working ok here. (not really much help I know, but)

OS type and version Ubuntu Linux 22.04.4
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0
Theme version 21.10
Package updates All installed packages are up to date

You mean here?? Or the terminal

you maybe right

I’m seeing the same thing, not working for me either … seems to happen with last update

Sorry, Let me rephrase that!
Webmin -> Tools -> Command Shell
Worked once with simple cd command but failed with anything else!

Virtualmin -> Terminal still working ok (though probably not relevant here)

Look like its in some sort of loop, same happens when I click clear history.

yes, this is what i mean. forever loop without result. Webmin → Tools → Command Shell. cannot remember what is the last work version. should be 2 version before that.

but working in terminal, result as below.


i think this is the webmin module issue, i have a VM running with webmin only which i don have virtualmin install. it also generate similar issue.

OS type and version Ubuntu Linux 22.04.4
Webmin version 2.111

Yes I tested on Webmin module first when I read your post.

My second post just attempted to clarify it worked initially with the simple cd command but then failed with a script/shell command.

I added the note on Virtualmin to clarify that I was aware you were referring to Webmin. Just in case others were going to attempt to use the option of running a command there instead. I realise that is not available to you.

thank for trying, hopefully webmin will relase a patch to solve this.

@staff any update on this ?

Oh, I’m sorry. I forgot to provide feedback. This issue was fixed the same day it was reported. It was a bug on the theme side. You just need to upgrade the Authentic theme manually using the Theme Configuration page to the latest development version if you feel comfortable doing so, or just wait for another Webmin release.

1 Like


Many thanks

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.