Time server sync

In Webmin> Hardware> System Time> on the Time server sync tab is a filed “Timeserver hostnames or addresses” Can some one please tel me what goes in there. I have tried many different thing and always get errors like below.

NTP time synchronization failed : Error : Name or service not known 3 Aug 10:45:22 ntpdate[29901]: can’t find host http://www.ntp.org 3 Aug 10:45:22 ntpdate[29901]: no servers can be used, exiting

NTP time synchronization failed : 3 Aug 10:46:35 ntpdate[29938]: no server suitable for synchronization found

Just enter the hostname of the time server there, no “http://” or similar. We’re talking hosts there, not web URLs. :slight_smile:

A list of public time servers can e.g. be found here: http://support.ntp.org/bin/view/Servers/StratumOneTimeServers

Hi Locutus

Thanks for your response. So you mean something like ntp.amnic.net or ntp.tbpl.com.au. If that is correct I have tried lots of different ones from the link you provided but in every case I get an error like in my last post. I have even looked at the configuration to see if there is anything that I think would help but I don’t see anything that would make the difference.

Have you tried entering it on your server and what result did you get? If you are getting the same or a similar result them maybe I need to report it to Jamie or Joe and see if it is an bug?

Thanks for you for your input

Yes, I have entered the timeserver of my hoster there (ntp1.hetzner.de), and that works without problem. I also just tried “ntp0.nl.net” as an example from the list I posted, and that works as well.

So no matter what host you enter there, you get an error that the hostname can’t be found? Maybe you have a general issue with name resolution on your server?

Hi Locutus

I just tried the two timeservers you have working and got this error.

NTP time synchronization failed : 5 Aug 00:43:15 ntpdate[23076]: no server suitable for synchronization found

Any suggestions what to look for with name resolution and where to find it

Thanks for you help

Okay, that message does not really look like a name resolution problem. Maybe some packet filter is blocking access to external time servers.

Where are you located, what is your hoster/ISP?

What reply do you get for these?

dig ntp2.fau.de ping ntp2.fau.de ntpdate ntp2.fau.de