Time on Server in Webmin - how to change

“Time on Server” in “System Information” is showing wrong time and I am not knowing where to change. Please help.



Click on Webmin, go down to the Search box on the bottom-left, and search for “system time”.

Click the module named “System Time” when it appears, and then on that screen you’ll be able to update the server’s time.


It shows the following message.

Searching for system time . . . . . . . . . . found 0 results :

No Webmin modules or pages matching system time were found.

The module is under the “Hardware” section of Webmin. If not, it might be disabled or not installed (which is unusual). Try the “Refresh Modules” link first in this case.

Under “Hardware”? No wonder I could never find it :slight_smile:

But yeah, to search for it, you’d have to search from within Webmin, and not Virtualmin. But now that Locutus explained how to find it, that should be even easier… Webmin -> Hardware -> System Time.


I could only find “Printer Administration” under Webmin -> Hardware

I have tried Centos 6, Ubuntu 12.04 and Debian but couldn’t find in any of them.

Can I download system time manually?


I’m not quite sure what the issue is there, but another option is just to use ntpdate.

If you run this command as root:

apt-get install ntpdate

That will install the ntpdate package… you can then run this command to update your system time with the atomic clock:


gave the below error

10 Dec 07:52:43 ntpdate[10826]: Can’t adjust the time of day: Operation not permitted

Can you post for CentOS too. I am using CentOs on other VPS. Thanks


Hmm, just to verify, are you running that command as root?


I am new to Linux but this is what I am trying to do.

Install OS at the VPS website.

Open Putty and login as ‘root’ and type the password.

Once it logs in I am trying to perform the above. Is this not root?

Do you have something similar to Windows ‘Run as Administrator’ even though the logged in user is administrator?


It sounds like your VPS may be limiting your ability to set the time (which may also be the reason the option doesn’t show up within Webmin/Virtualmin).

What VPS type are you using?


Using OneProvider and ChicagoVPS. Having the same menus on both VPS’s