This web page is not available VirutalMin cannot load any websites


I rent a dedicated server with 2GB RAM with a basic Intel Celeron and 1TB HDD, I run Linux Centos 6 on it. I installed Virtualmin via this:


chmod +x


I then installed two websites, one is a subdomain one is a normal domain. They both worked fine for 5 or so hours but they just domly went down and when I try to load it in a browser I get: “This web page is not available”. I have already tested it on two other different dedicated servers with the same installation method and it doesn’t work, it still gives the same error after a while. I have run these websites for a long time on another dedicated server previously until this error came up so I moved it to the Intel Celeron server to check if it fixed it and it didn’t. It always gives the same error on the browser: “This web page is not available”.

I can load Virtualmin fine on https://myIP:10000 so the webserver is working but I cannot access my sites so it seems like a virtualmin problem. The odd thing is sometimes it will magically appear again and start working, then 10 seconds later it will give the same message on the browser: “This web page is not available”. I have tested it on lots of other people’s PCs around the World so it’s not a problem with my PC or router.

I have restarted virtualmin via the command and I have also restarted httpd and mysqld many times but it still fails to work and gives the same error: “This web page is not available”. If you would liek to see the error here it is:

I really would appreciate it if anyone could help me out, this is a huge problem for me and I need to get it fixed ASAP.

Thanks a lot


What errors do you see in your error logs when this happens? Those are located in $HOME/logs/error_log.



DNS is correct, Trace looks correct and apache is running, virtualmin is reachable.
Using the domainname:10000 then virtualmin is served immediately.

I suggest to go to virtualmin - Services - Preview Website
then you know if the site is actually still working on your server.

If yes then apache can not serve the site to the world and there may be a problem with apache settings or per haps even the network settings

Also check the logs for apache access and error logs
check also the virtualhost container in the httpd.conf, is there the line ‘NameVirtualHost ip:80’ and < VirtualHost IP:80 >

I go to preview the website and it loads nothing for about 5 min and produces this error on the page: Error - Missing Content-Type Header.

The access logs don’t give anything unusual apart from a few different IPs trying to load the website. The error logs give an error like this: [client] File does not exist: /home/serverminer/public_html/robots.txt

There are also a few other ones saying “File does not exist:” in the Apache error log.

I checked the httpd.conf and both what you mentioned are included inside. Could it be a firewall or an attack from another machine of some sort? The odd thing is that it happens to all the Virtualmin servers I install on, the websites will go down again with the same domains. I was running fine a week ago for a Month or so and never had this problem before. I really appreciate your help and I would appreciate it even more if you could help fix this :slight_smile:

Thank you

EDIT: I keep on refreshing the page and every 10 or so mins it will load the website and then I will try refresh again and it will go offline again. It is almost as if it keeps trying to start itself up and something stops it like a conflict or something, Also if I go into SSH and reload the httpd and quickly try and load the website, it will load and then I will refresh the page and it will be down. It starts up and almost crashes but the error logs look clean?

I think you have to look at your website. Is it some kind of script like joomla or wordpress? Or is it homebrew?
This is the error the website is suffering from: Error - Missing Content-Type Header

So if you go into virtualmin - Server Configuration - Website Options and then switch the faulty domain to mod_php - restart Apache and look in the website preview again. Does it solve anything?

Also when you place a simple index.html (no code just a hello) in the doc root what happens then?

you want to disable your chatbox from for sure. Your website is depending on loading times from zopim and that takes very long. Cancel out anything that could slow things down just for testing purposes

I changed it to mod_php and restarted apache and it didn’t seem to change anything. What I do find strange is I currently have a few dedicated servers all with virtualmin installed on and I have all of them setup for the same domain with all the files. When I switch the domain to the different dedicated servers via cloudflare the website will work for a while and is usable then it will suddenly go down and display the error then I will go on cloudflare and switch it to another and it will work for an hour or so then go down then I will switch it again. This is just a temporary fix for my clients but I don’t have a clue what could be causing this. THis problem is only happening with my which doesn’t have zopim installed and I didn’t make it, it is a bought control panel which 100s of other people are using fine. It seems like a small setting which is messing everything up which is similar with all Virtualmin machines. I kept moving around my website and it seems to be stable at the moment for the last 5 or so hours but the isn’t.

Any ideas what could be causing this? and are currently very fast from where I am (Holland)
To me it looks like switching to mod_php has worked.
mod_fcgid will leave processes “hanging” and is more RAM consuming.

Other than this I wouldn’t know what causes your site to be unresponsive. You need to check server load, ram usage, cpu usage etc to start troubleshooting this. Also check MySQL connections and logs.

Questions like: Is it caused by lack of resources or per haps a php setting or Apache module conflicting with a script. It is hard to say and come up with a solution over the forums.
Per haps ask your ISP if any DDOS attack occurred which may have slowed down the network.

This is how I would approach this situation. Rule out possibilities 1 by 1. Hopefully Eric may have some ideas too.