This script cannot be installed, as this virtual server does not meet its requirements : Missing command fuser

|CentOS Linux 7.9
Webmin version 1.981
Virtualmin version 6.17
Django 3.2

It has not been possible to install django using Virtualmin pro, version. Are there any possible solution or step by step guide to install django on virtualmin?

Did you check the prerequisite; yum install psmisc? Try that and see if fuser command is OK

Done, with new error, nothing relevant coming on google search:

Python module MySQLdb is required …
Installing package python3-mysql …

Installing package(s) with command /bin/yum -y install python3-mysql ..

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base:
 * centos-sclo-rh:
 * centos-sclo-sclo:
 * epel:
 * extras:
 * updates:
No package python3-mysql available.
Error: Nothing to do

.. install failed!

… automatic Python module installation failed

Looks like you don’t have Python and pip. Will probably need to go back a few steps and follow the basics. Have a look at this link and see if it helps, make sure to read/check the options. How to Install Django on CentOS 7 | RoseHosting Once all the prerequisites been installed/setup - you can finish the install in Virtualmin. You may need python 3.6 and higher?

Everything done. Still not working.

backports.entry-points-selectable (1.1.0)
distlib (0.3.3)
filelock (3.3.2)
importlib-metadata (4.8.1)
importlib-resources (5.4.0)
mysql-connector (2.2.9)
mysql-connector-python (8.0.27)
pip (9.0.3)
platformdirs (2.4.0)
protobuf (3.19.1)
setuptools (39.2.0)
six (1.16.0)
typing-extensions (
virtualenv (20.10.0)
zipp (3.6.0)

What errors do you get when you start the install script, under Virtualmin Configuration is default Python command set to python3 in Advanced Options? Perhaps this is needed. Is it complaining about python3-mysqldb? Did you create create a virtualenv? You can run it outside Virtualmin.

Still not working.

Running Django on CentOS 7 is quite challenging (and much more challenging than years ago when CentOS 7 was current).

I think we’ll probably need to hide it on very old distros, as the dependencies may have moved on from what we can reasonably install using Virtualmin’s current dependency resolution (ideally we’d install a venv and use something like pipenv or whatever to resolve/install deps, but currently we use the system Python). I’ll try an install on CentOS 7 in the next couple of days and see if I can find a way to make it work…

1 Like

Think switching to pip and virtualenv would mitigate some issues. Old techies will make it work anyway but majority will get confused. Part of the problem may be mixing the different options and versions of python, pip and poo.

@Joshar_Group Would help if any errors can be shared. If not already installed, you may need Python and MySQL development headers and libraries yum install python-devel mysql-devel and yum install python3-devel.

YUP that is and has also separate file locations to handle and more , was lot of reading work to have some other things working then with python3 ( openstack things.)

I am looking at Python 3 default out of the box if possible after that. :wink:

So if @Joshar_Group just starting check other OS version for the box if possible , while those incompatible version problems only getting worse

CentOS 7 can’t have Python 3 as the default, I don’t think, as system tools still rely on Python 2. (But, of course, no one should be installing new systems with CentOS 7, regardless of default Python version. Everything in CentOS 7 is unreasonably old at this point.)

CentOS 8 has Python 3 by default.

YUP that is what i mean, also other parts are old Centos 7 , so better look into newer OS version if possible ?

I will upgrade the server to centOs 8 and try again, fingers crossed.

Problem solved by upgrading server from CentOs 7 to 8.

Maybe python 3 issues as suggested above.

Thank you all

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.