Theme not loading properly

Hello,

Starting a few weeks back (I cannot pinpoint the exact date or link this to a specific update) I think that my Authentic Theme is behaving weird. I have had the feeling for at least 10 different servers, all using up-to-date Debian 10 or Ubuntu 20.0.4, Virtualmin and Webmin and Authentic Theme up to date as well (6.16, 1.973, 19.73).

To be perfectly clear, this is a feeling, I don’t get any errors, just weird behaviors like:

  • when clicking on any item on the left, right side not being changed accordingly
  • very often when clicking on the left tab “Virtualmin”, endless loading of the left menu, being forced the click again
  • having real difficulties to get the “system information” screen on the right, being forced to click on another item on the left (and often being forced to click to at least one or two before I have one that is able to change the right side) and then clicking again on “virtualmin” to get “system information” (happened just right now just to be able to get my installed versions)
  • when first arriving on dashboard, left menu loaded but right side stays “gray” without anything

I’m not even sure this is a theme topic. I’m using the latest Firefox or Safari or Brave (Chromium based) on a MacBook Pro M1. And I’m finally wondering: is clicking on either “Webmin” or “Virtualmin” tabs the right way to go back to system information ? but if I click “List servers” and try then “dashboard” is does not move and stays on the list of servers although loading seems to be finished. It seems to work slightly better on a colleague PC but he still get stuck with the endless menu loading and similar behavior from time to time… I also tried using a VPN or not, same …

I was just wondering if somebody else had seen the same behavior of if I was to check something else here locally … ?
Thanks ! Pierre

@Pierrot,

Have you checked the developer console in your browser (typically by right clicking on page and choosing “Inspect”) to see if there are any client side issues. Further, have you tried a “hard” refresh (F5 or clicking the “reload” button in browser) to see if things are just stuck.

I cannot say I’ve been able to replicate the issue you are having so I am wondering if perhaps its from the client side rather than server.

BTW, what are the specs of your server (RAM, CPU) and what all is running? Is your server under heavy loading?

If the above doesn’t help, I’d be happy to setup a screen sharing session to try and identify what might be happening, but I suspect it isn’t server side at this time though with a few more details as requested above, this opinion might change.

Best Regards,
Peter Knowles | TPN Solutions

1 Like

I’ve had an issue a couple of times where the central window that has the folder stack takes forever to load. I’ll click on file explorer, then that middle section that displays the overall list of folders starts to load. Meanwhile, the selected folder display over on the right side of that is already loaded. A few seconds later that middle overall folder display will finally load.

It’s odd. Doesn’t happen all the time, just once in a while. I’ve just lived with it.

Hi, Pierre.

I cannot reproduce the issues you’re talking about. It sounds like a big breakage. It wouldn’t have been unnoticed.

Is there a way for me to login and see it myself?

Does the same issue happen when Virtualmin is accessed on Intel x86 processors? Is your DNS configured correctly? Does your server have static IP configuration?

Hello,

As I said I get the same behavior on all my servers (at least 10 of them), ranging from VPS’s with 3 cores and 6gb and 150gb SSD to dedicated with 32gb and Xeon 8 cores and 1.9tb NVMe drives, none of them being overloaded. But I definitely see this more on the smaller machines and less on the dedicated ones …

@tpnsolutions: The “inspect element” does not return any console error.
@Gomez_Adams: yes happens to me as well
@Ilia: I guess we can arrange for you to log into one of these servers, I have 2FA authentication set up for the root user, but maybe I can create another user ? All servers have fixed IP addresses. As I said testing from a regular HP PC same results.

Pierre.

Hello,

Weird: for Ilia I started creating a new user, I gave him access to all modules … I then tried logging in with that new user and I went in ok. There I was presented with one available update 1.974 (from the previous 1.973). I refreshed the available updates from another browser with my usual root user and that update was not presented, weird.
After updating Virtualmin asked me to re-run the initial setup which I had to do with both users … and then everything seems to work better !!
And that update is not proposed on any of my other servers, is this normal ?

Pierre.

Yes, you could create another user using Webmin Users module and adding modules to run tests with.

All servers have fixed IP addresses. As I said testing from a regular HP PC same results.

Does the same problem happen if you access it using IP:10000 address?

Did you install Virtualmin using official install.sh script? Did you pre-install Webmin manually (not recommended) or just did full install using mentioned install script?

Hello,

Yes accessing the one I am currently test seems to improve when using IP. Yes Virtualmin was installed with official install.sh on a fresh debian 10.
I’ll check my network / hostname config for that server before going further …

Pierre