"The user's password must be changed before logging in for the first time" on Samba / Windows

OS type and version Debian Linux 11
Webmin version 2.000

Hello there.

I’m having trouble getting my Samba server to work all of a sudden on the Windows side. I can log into my server via Webmin, but I can’t map the network drive in Windows 11 because, when I use my credentials, I get the error message, “The user’s password must be changed before logging in for the first time.” When I look at my Samba settings in Webmin, I see myself under Samba Users, but the same password I use to log into Webmin will not work in Windows. I’ve tried logging in with no password at all, and I get the same result.

Is there a setting I need to change?

Bumping due to lack of reply.

iirc, samba user does not equal system(webmin) user. maybe you need to map samba user to system(webmin) user for this method to work… not sure how, haven’t touched samba in ages…
or add a new samba user with a different password , and login with those from windoze.

Thank you, but I’m afraid that’s not giving me quite enough detail to figure out what to do. I need some very literal “click here, then here” instructions.

Lack of reply is probably that most folks here only know about web hosting. Samba is a bit out of our wheelhouse. Yes, Webmin has a Samba module, but I haven’t managed a Samba system in at least 15 years.

It may be that somebody here will happen to know, but what you’ve got is a Samba question. Just because you’re looking at the configuration of Samba in Webmin, that’s unrelated to the problem (I think); you’d have the same problem if you edited the Samba config files in a text editor in the same way. You may find help more readily in the Samba community.

I see, thank you. I’m just running a little home NAS here and trying to figure it out.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.