The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin virtual server home directory is /home

Docs:
https://www.virtualmin.com/documentation/web/multiplephp

I installed in my CentOS7: apache + php 7.2 and 7.3 + php fpm + mysql. All right!

PHP Version 7.3.16
System Linux vmi2334 3.10.0-1062.el7.x86_64 #1 SMP Wed Aug 7 18:08:02 UTC 2019 x86_64
Build Date Mar 17 2020 10:18:38
Server API FPM/FastCGI

The problem is that the tutorial made my public directory look like this: /var/www/html/

and it appears:
SuExec cannot be used to run PHP scripts in CGI or FCGId modes : The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin virtual server home directory is /home. CGI scripts run as domain owners will not be executed.

I’m new to Webmin, before I used WHM / cPanel.

Even being a newbie on servers, I believe that the error may be the configuration file of the Virtual Host.

Does anyone know how i fix this?

And finally, how to install Let’s Encrypt (free ssl) from the command line?

Thanks

Don’t follow that tutorial if you’re going to use Virtualmin.

Use the Virtualmin install script on a freshly installed OS.

But, version 6.09 of Virtualmin will work with this configuration (rather, it’ll simply turn off suexec as an option if /home isn’t the suexec_docroot) if you are not going to use suexec. (I still don’t recommend you try to munge Virtualmin into a system that is wildly different from our default configuration. I’ll literally take you weeks to sort out all the quirks, and that’s if you’re pretty experienced with Linux system administration.)

1 Like

Thanks for the answer. I agree that you have trouble changing and I accept your opinion.
But the standard installation didn’t work for me, it came with nothing. I tried but I had to install up to ftp and it was a lot of work and didn’t change php 5.6 in any way.
For this tutorial, following the command line everything was faster and it worked, I have php 7.3, php-fpm and fast cgid, the server is perfect in all the tests I did.
Now I just need to make him recognize the / home of the sites.
If anyone else can help, I appreciate it.

lol, that’s not all you have to do, but if you’re happy, we’re happy. Best of luck, but I can assure you you’re making a lot of work for yourself for no benefit.

The default install includes PHP 7.2, and switching to a newer version is as simple as installing the right packages and doing a config check (though you need 6.09, as earlier versions were quirky and annoyingly finicky about choosing a newer version for PHP-FPM).

1 Like

Thank you again.
But for me the only version that had by default was 5.6
How do I install the standard version with php 7.2? Do you also have php-fpm?

Thanks and I apologize if I’m confused by this, as I’ve been working on it for 40 hours and I still haven’t been able to use the server. I’ve read many things and it seems that I’m just going around.
My specialty is wordpress. I just need to run the latest version of php, if possible at 7.3 and mandatory with php-fpm / FastCGI

Thank you @Joe

Edit:
other people in the company are also working on it and to no avail. I thought it might be my fault that I didn’t see the standard version, but everyone confirmed that the default version of the installation was 5.6

default phpinfo:

PHP Version 5.6.40

System Linux vmi2334 3.10.0-1062.el7.x86_64 #1 SMP Wed Aug 7 18:08:02 UTC 2019 x86_64
Build Date Mar 17 2020 07:46:07
Server API Apache 2.0 Handler
Virtual Directory Support disabled

It is included in the default install provided by install.sh. Here is the yum group that install.sh installs for php-72 packages: https://github.com/virtualmin/virtualmin-yum-groups/blob/b75d5d374c07530d7d3198935398b770e60a1f6e/virtualmin-centos-7-comps.xml#L28

Of course.

“Default” is not the same as “only”. PHP 7.2 is part of the default install on CentOS 7. Virtualmin should list both, though it will use the OS-provided default (5.6) by default…you’d need to tell it to use a different version.

ok, i will test and send the results today.
thank you for your support. I’m working with 3 people and nobody is a server specialist so it ends up getting confused and often the paths are different and wrong.

Thank you @Joe
it’s almost working

I just reinstalled Virtualmin as instructed. I was able to activate version 7.3 again from php, but when I select php-fpm the error appears
[Mon Apr 13 19:41:02.618800 2020] [proxy:error] [pid 24098] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:8000 (*) failed
[Mon Apr 13 19:41:02.618858 2020] [proxy_fcgi:error] [pid 24098] [client 186.204.102.165:54624] AH01079: failed to make connection to backend: localhost

server configuration -> website options -> FCGId (CGI/FastCGI) - work fine
But FPM (FPM/FastCGI) this does not work

7.3 didn’t come from the install script. Did you get it from SCL? If not, it’s likely Virtualmin doesn’t know how to interact with it.

You’re right. With php 7.2 it worked perfectly.
I’m sorry I confused
Thank you @Joe

PHP Version 7.2.24
System Linux vmi2334.contaboserver.net 3.10.0-1062.el7.x86_64 #1 SMP Wed Aug 7 18:08:02 UTC 2019 x86_64
Build Date Nov 4 2019 10:24:55
Server API FPM/FastCGI

cgi-fcgi

php-fpm active

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.