The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin virtual server home direc


I just installed Virtualmin from the .deb packs in a Debian 6.0 system.

When I hit in check the configuration I get:

“The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin virtual server home directory is /home. CGI and PHP scripts run as domain owners will not be executed.”

any ideas of how to solve it without recompiling suexec?

best regards,


We’d recommend installing Virtualmin using the script available in the Downloads link above, as there’s a lot of configuration that has to be done to get everything working.

However, if you’d like to perform a manual install, instructions are available here:

Installing VM from install gives me an error when mailman, so that’s not an option for me, I followed the MANUAL install, anyway I ALMOST solved it changing the suexec directory to /home as indicated in VM manual installation, however the site runs fine but I still get DIRECTORY UNWRITABLE, so I deduce apache is loading the site as www-data and not as the owner of the sites…

public_html and all the files inside it are owned i.e USER1

Directory Permissions
administrator/components Unwritable
administrator/language Unwritable
administrator/language/en-GB Unwritable
administrator/language/es-ES Unwritable
administrator/language/overrides Unwritable

Any ideas of how to solve this?

Yeah, it could be running those via mod_php and not CGI/FCGID.

If you go into System Settings -> Re-Check Config, does everything check out okay? Or does it see any problems? There’s some problems with Apache/PHP that it can detect, that could be causing the issue you’re seeing. In particular, I’m curious if it detects an issue with the SetHandler lines in the php5.conf file.


Hi Andrey,

Now my php files are handled uncorrectly ie:

I got in recheck:
The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Your system has 15.69 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.
BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Apache is installed.

Webalizer is installed.

MySQL is installed and running.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

SpamAssassin is configured to be run from the global Procmail configuration /etc/procmailrc, which is not needed as Virtualmin will set it up on a per-domain basis.

What PHP problems are you seeing?

I get a “Domain not found” error when trying to browse to your site.


I deleted the server and I installed again from a backup. (I’m doing it right now)

The php problem that I’m seeing is that Apache downloads the PHP file instead of executing it.

I have sites that work fine, and some others where this problem happens.

I’ve touched every configuration I know putting Addhandlers for php but it keeps doint the same, downloading the php file.

Yeah, manual installations are very hard to get working properly :slight_smile:

If you’re using CentOS – you have to make sure you’re using a version of Apache with suexec compiled to point to /home, rather than the default of /var/www.

That’s explained in the manual installation guide – and you can find that Apache version in the Virtualmin software repository.


Hi Eric!,

I changed everything that’s in the manual installation doc that’s the weird thing. I think it’s something in the configuration of the servers because this servers are from another server, not created from scratch.

Some domains work nice, and some others dont. I’m thinking in uninstalling everything but Aptget it’s still hanging in mailman so I dont really know what to do.

What output do you get if you run this command:

cat /etc/apache2/suexec/www-data