The Suexec command on your system is configured to only run scripts under /var/www, AGAIN!

I usually get this error when installing the GPL version on the latest CENTOS 7 version (1810 iso). I’ve seen issues going back to 2008 - not sure why this is happening.
Procedure for install:
Install Centos on VM from iso using minimal plus mariadb options.
Then I follow instructions on virtualmin download page:
Then I run install script:
sh ./
Installation doesn’t show errors - go to Virtualmin and after going through the installation online I run the check configuration and boom I get this error.
Should I be running a specific option when I install Centos? Minimal install only?


A common cause for that error on CentOS is if some third party repositories are being used there.

What is the output of these commands:

dpkg -l httpd ls /etc/yum.repos.d

dpkg-query: no packages found matching httpd
CentOS-Base.repo CentOS-Media.repo CentOS-Vault.repo
CentOS-CR.repo CentOS-SCLo-scl.repo epel.repo
CentOS-Debuginfo.repo CentOS-SCLo-scl-rh.repo epel-testing.repo
CentOS-fasttrack.repo CentOS-Sources.repo virtualmin.repo

Hey Andreychek

So I fixed it by installing and enabling apache (again??) -which is strange because I assumed that apache was already installed. I installed Virtualmin with no options hence it would install the full LAMP stack be default - not at all sure why this error but anyway it is fixed. All good now. Thanks for your help

Ah durnit I gave you the wrong command above, “dpkg” is for Debian/Ubuntu systems, we should have run an “rpm” command instead.

But, I’m glad to hear you got it working!

And yeah I’m not seeing any third party repositories there, it’s tough to say why that wasn’t working previously.