The quota limitation for disk usage in /home/

Hi there. I’m new to Virtualmin.

I was about to create a Virtual Server and scope via ssh the website from other server so did I… almost.
While transferring files an error occurred: “No space left on device” so i went into Account Plans configuration and increased Disk Quota to 1TB.
Then I tried to scope again but the same error appears.

How can I deal with it?

Ok, i reinstalled the my whole VPS server into Ubuntu. Previously it was Debian. Now everything works without problem.

But although I’m still trying to find out what was the Debian problem. (A partition configuration?)
When i used df command to see some details about the disk - there was no partition like “home” or any which would contain “home” directory.


Im glad you found fix for your self. Its a bit strange that it did not worked for you (im on debian and), it did worked for me, I guess you’ve done something wrong or perhaps you’ve installed debian as whole on one partition (without /home) which I did not and it worked all.

When there are mysterious “no space left on device” errors, and it isn’t quotas, it is almost certainly inodes.

Use ‘df -i’ to check. If you’re out of inodes, it almost certainly means the system (or more likely a web app) has been exploited, or something has gone awry that has created millions of files. I saw it recently on a user’s WordPress installation that had the W3Cache plugin exploited to host millions of spam pages. Cleaning up the mess resolved the “disk space” problem.