"the default master DNS server localhost is not a fully qualified domain name."

Can I get some help with this? This message always appears when I check the server for errors, I’m new to virtualmin and linux servers in general. I’m using Debian,

What exactly am I supposed to change to fix this? When I do ‘hostname’ and ‘hostname --fqdn’ both show domain1.com which is what I can use as a hostname if I understand correctly.

I’ve tried changing various settings in DNS BIND, but I don’t know what exactly to do. I don’t want to delete something and mess the DNS settings up.

Picture 1 is what comes up under DNS BIND settings, picture 2 is when I go to the localhost entry, picture 3 is the ‘all’ DNS settings for my first domain; I only have 2 domains configured, the second would be identical to the first in settings.



Hmm, there may be two issues there actually :slight_smile:

In theory, your hostname should be in the format “host.domain.tld” – though if everything else is working other than that warning you’re receiving, I wouldn’t worry to much about that.

As far as the warning about “localhost” being the default master DNS server – if you go into System Settings -> Server Templates -> Default -> BIND DNS Domain, what is “Master DNS server hostname” set to?


It just says ‘localhost’

Am I supposed to make it the actual external IP address of my server? And would changing things in this mean I have to ‘remake’ the server, or does template just mean I can change the settings

Edit: I set it to default and I -think- it’s getting the default hostname as domain1.com now because the warning messages disappeared

In regards to having a ‘correct’ hostname, how would I do that? If it’s supposed to be host.domain1.com can I just do ‘Hostname host.domain1.com’ or do I have to go and make a subdomain there and set up DNS zones for it


Yeah, the change you made to "“Master DNS server hostname” should be just fine.

As far as changing your hostname – if you aren’t seeing any issues you may just want to keep it the way it is, as there are a number of things to update if you change that. Once you change the hostname, you’d also need to update /etc/hosts, and the mydestination line of /etc/postfix/main.cf. You would also want to go into the domain.com Virtual Server, and add a DNS ‘a’ record for host.domain.com.