The Apache SSL Website enabled option is no longer available

Every day has its sorrow. Having fixed one thing, I find another.
When I create a virtual server there is no Apache SSL Website enabled option and therefore Virtualmin does not create the Let’s Encrypted certificate.
I have to create it with:
Manage Virtual Server / Setup SSL Certificate

On what other option does the presence of this one depend?

OS type and version Debian 12
Webmin version 2.105
Virtualmin version 7.10.0
Related packages SUGGESTED

All Virtual Servers are created with non-ssl and ssl enabled and it should request Lets Encrypt.
Check the Virtualmin Confuration SSL settings.

It defaults to on, and defaults to fetching a certificate, if it can.

I realize that I have opened many threads, but it is also true that strange things happen.
This is my panel for example; it is the same as yours and is one of the configurations checked before creating the domain and immediately after, when the certificate has not been created.

Yesterday morning I did the reset of the server and regenerated it from scratch using all your observations, suggestions and criticisms collected in recent days.
I wrote down everything and followed the installation step by step.
Then here’s the news you don’t expect.

The server will be used to manage only two domains in production and some subdomains that will be used for testing and which will then be removed once the work is finished.

I could consider the server configuration complete, if no other unexpected problems cropped up.

When you create the domain, does it complain about anything? Especially the requesting of ssl.
I never had issue creating new servers and I pretty much use default settings.

I see quiet few new users that have no experience with DNS and running mail and web servers expecting everything to work, its not that easy.

Forgive me, I don’t deny that I have little experience with Virtualmin and Webmin.
The questions I ask are also to learn better, where I haven’t found answers in the documentation or online.

With the configuration I posted previously, when I create a new Virtual Server the available options are these and the one for Apache SSL is not there.
During creation I don’t see the certificate creation task which I then have to generate manually.

Mine is a test environment specifically for experimenting with Virtualmin and its features; so, the server was formatted and installed to scratch several times and when creating the VS the option for SSL was there and the Let’s Encrypt certificates were always generated automatically.

So now, either there is some other option / configuration somewhere else that I got wrong or forgot, or I’m led to think that there is a problem generating the certificate for the same domain multiple times even if the server has been reset.

“formatted and installed … several times” that sounds to me like a route to a broken system.

Virtualmin/Webmin should be installed on a clean Grade A system - clean means nothing else installed.

Experimenting is not a good idea. just learn how to use the system by taking one small step at a time.

Doesn’t “formatted” imply a clean OS install?

LetsEncrypt do have limits on duplicate certificate creation.

Probably not relevant, bus I have had problems over the last day of creating a new domain and getting a LE certificate for it. I ended up creating the domain on my test system using Vmin 7.9 and then transferring it to my production server with 7.10.

Of course, both the VPS and the dedicated server were completely installed from scratch, including Debian. Virtualmin and Webmin were installed with the official scripts.

Now websites (the only one in production and the test ones) are operational. The only mailbox is also operational.
Let’s say I can finally work on the server. There are a couple of things that need to be completed, but they don’t stop me.

I absolutely had to experiment with installation and configuration.
I use Webmin often, but only for visual verification of the installations done by hand.
For Virtualmin I started from scratch. I read the documentation, forum posts, and various online pages.
If something didn’t work, there was no point in wasting time trying to fix it. Reset! And a new installation begins, clean and avoiding previous errors.

There are still things that don’t convince me in the Virtualmin configurations, but which I can then fix by hand. One is this one that I pointed out at the beginning: the certificate that is no longer generated automatically.

I wonder if I should create separate topics or group them all into one topic because all the reports could be related.

Almost always separate topics.

I think there is a problem here in the latest version of Virtualmin, but I came into this topic thinking you were just looking for something that’s no longer supposed to be there.

This thread has gone it too many directions for me to figure out what’s wrong, though.

@Ilia did something else break with SSL websites in 7.10? We had a lot of flapping (UI removal of SSL Website option, defaults changing in a couple of previous versions, etc.). I get the impression we’re still breaking stuff in this area in new ways on every release. And, it seems like it’s broken in a way that is wholly opaque to users…mysteries are the worst kind of failure.

Do you mean when creating a new domain, SSL certificate for the domain isn’t requested automatically? If so, does it work if Request Let’s Encrypt certificate at domain creation time option in Virtualmin Configuration is set to Yes and skip connectivity check or it still fails?

I remember that some changes were made to the default option for validating the domain before the initial SSL certificate request.

It is set to “Yes”

As I was saying, the server is operational and therefore I don’t think of doing any other tests, resetting everything and new installations.
The problem I report here is that of the SSL certificate which is not installed automatically, but I solved it by installing it manually.

I will report the other “problems” separately, separately.
If you think I can help, I’ll be more than happy to do so.

Yes or Yes and skip connectivity check?

It’s a dedicated server in a server farm, I don’t need to check the connectivity.

Does it function properly with the Yes and skip connectivity check option enabled instead?

Now I changed the setting, deleted a Virtual Server and created it again.
It worked now, but I see no reason why “Yes” alone shouldn’t work.
With what I pay for the server farm, the minimum they have to ensure is connectivity.

If you go to Logs and Reports → Check Connectivity page what error do you see exactly?

I have the GPL version. The " Logs and Reports → Check Connectivity" menu item is not active.