That old chestnut... The following virtual servers' domain registrations have expired

Ok, so one of my domains was due for renewal yesterday, but I renewed it a few weeks ago.
whois gives me; Registry Expiry Date: 2023-09-14T02:54:45Z

But I’m still getting the warning displayed.
How do I get virtualmin to check the whois again?

-Pook

SYSTEM INFORMATION
OS type and version Ubuntu Linux 22.04.1
Webmin version 2.000
Virtualmin version 7.1-1

The answer to your question is: on the Virtualmin dashboard, hit the refresh button on the top right corner. It takes a few seconds for the operation to complete.

Caveat: whois records are updated at different frequencies (and sometimes quite infrequently) so Virtualmin might continue to show you the warning even after you refresh the Dashboard data. If so, it will eventually go away; just ignore it till then.

OK, so it’s been 4 days. How long should it take?

If you think its a bug, report to staff

Are any status updates happening? The updates happen regularly. No status check takes more than 24 hours to update, unless configured otherwise. (i.e. have you disabled automatic status updates, or are they not running for some other reason)

It just checked for packages and found some that need updating so it’s doing something?

Also realised I put the wrong system info in at the top.
This machine is actually still on Ubuntu 18:04

SYSTEM INFORMATION
OS type and version Ubuntu Linux 18.04.6
Webmin version 1.999
Usermin version 1.854
Virtualmin version 7.1-1
Theme version 20.02
Package updates All installed packages are up to date

The fact that you had to check and didn’t already have a warning about outdated packages means the Virtualmin scheduled status checks are not happening. Which either means you’ve disabled it, or it is stuck for some reason and a stale lock is hanging around (a system reboot would clear it, most likely, or you can manually dig into the Webmin log and find out what file is hanging it up and delete it, probably).

In System Settings->Virtualmin Configuration->Status Collection to find out if you’ve turned it off. If you have, turn it back on, and don’t turn it off if you want Virtualmin to be able to monitor any statuses on your system, since it has to run sometimes to do so. (It may be reasonable to run it less often than every five minutes on a lightly used system on a small VM. But should never be less often than daily…because at that point, things can get messy.)

Actually, I may be wrong about this. I don’t see where domain registrations are checked as part of this job. I don’t know where the heck cert expiry checks happen. I’ve asked @ilia to fill us in on what could be going wrong.

Virtualmin has a status collection function that checks if domains or certs are about to expire, among other things. This particular error checks for DNS registrar expire, which is usually done with the whois command.

Can you post the full output from whois here?

I see what causes this issue. This domain expiry data is cashed for 7 days.

At the moment, you can work around this issue by opening a domain config file from Virtual Server Summary by clicking on Domain ID while holding Alt (Option on Mac) key. It will open domain config file in editor mode. Then find all records starting with whois_ and delete them, and save the file.

I will see how we can solve this problem, while not affecting other use cases for this feature.

Alright, next Virtualmin release will have a button to force-refresh domains expiration status:

2 Likes

Thanks for this, I forgot about the thread for a bit. Ubuntu 18.04 finally received the Webmin update 1.999- > 2.001 and that made it recheck.

Thanks for your feedback. I am glad it worked for you.