Syntax error on line 211 of

Hello again Joe,

Sorry to be so bothersome but I have another problem that I think is a simple one to answer… I hope!

Now that virtualmim creates the server, when I try to view my newly created site, it defaults the address ( to the default web server pages.

When I try to view the directory indexing in the apache webserver module, and i add a html or web page type. I then try to "Apply Changes" to the apache webserver.

this is what comes up after picking apply changes:

Failed to apply changes: Syntax error on line 211 of /etc/apache2/httpd.conf: Invalid command 'SuexecUserGroup', perhaps mis-spelled or defined by a module not included in the server configuration

When I open the httpd.conf, starting at line 211, this is what I see:

[code:1]Line 210 <VirtualHost>
Line 211 SuexecUserGroup "#1001" "#1001"
Line 212 ServerName Myserver
Line 213 ServerAlias
Line 214 DocumentRoot /home/myserver/public_html
Line 215 ErrorLog /home/myserver/logs/error_log
Line 216 CustomLog /home/myserver/logs/access_log combined
Line 217 ScripAlias /cgi-bin/ /home/myserver/cgi-bin/
Line 218 DirectoryIndex index.html index.htm index.php index.php4 index.php5
Line 219 <Directory /home/myserver/public_html>
Line 220 Options Indexes IncludesNOEXEC FollowSymLinks
Line 221 Allow from all
Line 222 AllowOverride All
Line 223 </Directory>
Line 224 <Directory /home/myserver/cgi-bin>
Line 225 allow from all
Line 226 </Directory>
Line 227 UserDir "/home/myserver/public_html"
Line 228 </VirtualHost>[/code:1]

Considering that when trying to apply changes to apache and I get the above error and in my .conf file I see referance to this… Im assuming Apache can not find the SuexecUserGroup and stops there thus causing the server to not rout to the proper "myserver" and catches it in the server default (or server default web site) which is located in /svr/www/htdocs/ directory.

Again, sorry to be so bothersome and I appreciate your time, wish I could return the favor some time!

Also, I found (through a few searches) that you suggested to enable the a2enmod suexec. I can not seem to find it but when I go into the "Configure known modules" under apache, i find mod_suexec. I check it and pick th "Configure" box then try to apply or start apache and get the same thing.

When I go back into the module configuration I find the mod_suexec is unchecked.

Hey Dave,

As Tony mentioned, you’re missing the suexec module. How you enable it depends on your OS and version. a2enmod is a Debian/Ubuntu command, I think (I can’t really keep up…I have five distros and a bunch of versions on my plate now, and I’m confused all the time). :wink:

I’ll be releasing the Virtualmin automated installer for Virtualmin GPL tomorrow (I’m guessing this is GPL, since Pro should get all of this setup right from the start)–so this pain might go away if you’re using CentOS 5 or Debian 4.0 (some other platforms probably will follow, depending on demand and how much free time I can find to maintain the repositories).

Hi Tony, Thanks, found the in my /usr/lib64/apache2-prefork/ and /usr/lib64/apache2/ dirs. I tried to do a ./suexec -v and got a no such file. in doing a ./ -v I get "Segmentation fault"

This in both dir.

Joe… Thanks! unfortunatly, it seems I am running a less popular OS in SuSE 10 :frowning:

Yes, I am using GPL for now, I want to purchase a business class server systme, either Rack or blade in the next year but until then, and since this is more a hobby and serving personal web sites for the family and non profit organizations such as the Fraternal Order of Eagles local club I belong to, i dont think my wife would look to kindly on spending more money, expecially since im on L&I at the moment.

Any idea when you might have this ready for SuSE?

Any idea when you might have this ready for SuSE?

I’m afraid it’ll be a while.

Our SUSE user base can be counted on my fingers (while CentOS and Debian and Ubuntu and Fedora users all number in the hundreds). OS support is the single most expensive thing we do…so we have to be picky about what systems we support. There’s just the two of us, for now.

That said, SUSE 10 is supported by the Professional installer (kinda…it’s still the least smooth OS to install on because yast is really ornery to control from a script)…so, porting it to GPL isn’t nearly as big of a job as doing it from scratch. The big thing is that it adds a new repository and some new packages to be maintained.

As for the problem:

I tried to do a ./suexec -v and got a no such file. in doing a ./ -v I get "Segmentation fault"

You can’t run mod_suexec directly. It’s a library for Apache.

I believe SUSE has a file in /etc somewhere (maybe sysconfig) that lists what modules Apache should load. Or you could just add it directly with LoadModule and AddModule. Yast probably wants to control it via some stupid file full of shell variables (I don’t think very highly of yast, I’m afraid…it’s more a problem of them designing the system for the convenience of the yast developers that bugs me, rather than the tool itself being defective)…so maybe startup yast and see if it’ll let you add modules to your Apache configuration.

It’s after 2AM here, so I’m gonna hit the sack, but in the morning, I’ll boot up my SUSE devel vm and give you more detailed instructions on how to get suexec enabled.

Oh, and I’m about to cause you a bit more consternation…The default SUSE apache2 package is going to have to be rebuilt to work with Virtualmin, if you’re going to use suexec (suexec has to be told at compile time what directory it’ll be running things in, and it’s built with something other than /home by default).

I’m afraid life is hard sometimes.

Actually, I can make our SUSE 10 apache2 package available outside of the repositories so you can just download it. That’ll solve that problem for you.

Yeah, I’m too tired to be much more use. I’ll get back to this thread in the morning.

Hey Joe,

Ok, 1st, without you and Tony’s reply here, I would not be up and running! with your two suggestions, expecially yours Joe, I found how to fix this issue.

So, it is the least I can do to give you step by step instructions to fix this just in case it comes up again.

**logged in as root on the server do the following**
  1. Open Yast2
  2. select "Network Services" from the options.
  3. select "HTTP Server"
  4. under settings, highlight "Modules"
  5. Select the "Edit" button.
  6. Find "suexec" in the list, most likely (like mine) it is Disabled.
  7. Highlight "suexec"
  8. Pick the "Toggle Status" button so that it now shows a status of "Enabled"
  9. Pick OK
  10. Pick "Finish"

Yast will reset the configuration of Apache and everything should work.

Unbeleivable that it was that simple, i have been fighting with this box for over a week to get it working. I guess one lessen I have learned is to not work on this after taking muscle relaxers and perkaset :wink:

If you would like, I would be more than happy to place a link somewhere on my site as I am a FIRM beliver in customer support and yours is by far the best!

Hey Dave,

Thanks for the update, and the yast configuration goodness.

If you would like, I would be more than happy to place a link somewhere on my site as I am a FIRM beliver in customer support and yours is by far the best!

We always welcome word of mouth. We’re a small company, without a big budget for marketing…so customers talking about us is the best thing we’ve got.

We’d also encourage anyone signing up for hosting to ask, politely, if the host offers or plans to offer Virtualmin. We’ve begun approaching hosts directly, and we’re getting a lot of, “yeah, we’ve had a few people ask about it, but not enough to justify the expense of adding and supporting another platform”…we need to cross that threshold from “not enough” to “overwhelming demand”. :wink:

We’d be particularly enthusiastic about signing deals with the hosts that currently offer Webmin, as the “support” burden for them would probably end up smaller, since Virtualmin is easier to use for the purpose of hosting.

Hi there…

I know what you are going thru, had the same trouble with all of this. :wink: Did you compile Apache with SuExec support? Looks to me like Apache does not know anything about the existence of it!?

Try this… locate the "suexec" binary on your machine. For me it is inside the Apache folder: /usr/local/Apache2/bin/suexec

Then do:

cd /your/path/to/suexec

./suexec -V

If you can not find it then you have to recompile Apache again with SuExec support. Like so:

--with-suexec \ --with-suexec-bin=/usr/local/apache2/bin/suexec\ --with-suexec-docroot=/your/path/to/your/hosting/directory \ --with-suexec-logfile=/usr/local/apache2/logs/suexec.log \ --with-suexec-safepath=/usr/local/apache2/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin \ --with-suexec-uidmin=500 \ --with-suexec-gidmin=100 \

Post the output of "suexec -V" if you still have trouble with it.