Switch to Server's Admin

Guys, I accidentally clicked on Switch to Server’s Admin and now it’s only displaying one domian. Does anyone how to switch back, as there are no links for it. Thanks

Ubuntu LTS

OS type and version: REQUIRED
Webmin version: REQUIRED
Virtualmin version: REQUIRED
Related products version: RECOMMENDED

Log out and log back in with the regular username and password.

1 Like

Great. Thanks… And one more thing. In this new install I can’t find the Edit Databases tab on all domains. I tried going into Admin Options/Owner’s Limits and added DB manage capabilities but it still not showing. Do you have any suggestion on how to make it work, please? TY

You have to make sure the user of that Virtual Server has permissions to edit the data bases.

Example: As root, you can edit any database. As a user, you may not have that permission unless you set it.

Here’s what I would do: Go to the Virtual Server where you can’t find the edit database tab. Log in as root/admin. Then you should see the data base tab. While there, click the edit users tab (4th from the top I think) and select the regular user for that Virtual Server and see if that user has database permissions.

If it doesn’t then you’ll need to add permissions to that user.

O.K. I have tried loggin in as root on all domains and still can’t find the tab. How do I give root user permission?..

I may have said it wrong.

OK, a picture is worth 1000 words, so here you go. One of my domains is exposingwot.com. When I go to that VS and click on the Edit Users Tab, I have two users listed. Over on the right hand side you can see that both users have access to the databases.

That’s what you’re looking for: to see if the users you have on the domain you’re working on actually have permission to use databases. If it says NO in that area (red box) then you need to edit those users to grant them permission to use the databases.

O.K. I’m sorry but, I don’t have Databases?.. I have DAV?.. Is that the same, because I added permission to users and tab is still missing. TY

If you’re talking about WebDAV, no. Not even REMOTELY the same thing. If you’re not running either MySQL or MariaDB then you’re not going to see any database tabs.

WebDAV is more of an HTML thing as best I remember. It doesn’t utilize databases.

Go to the Edit Virtual Server tab and see if you have MySQL Database Enabled checked. If it’s not checked, check it and hit save.

Thank you very much. That explains alot.

1 Like

O.K. I’ve decided to delete droplet and re-install VM. I don’t know what my friend did but, installed it incorrectly. But, i do have a question. How can I back up a single domain with all its files to move to a new server/droplet?.. I need to move entire website with its database. Thanks

Backup and Restore should handle that fine.


Great. Thanks for your input.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.