Switch to FCGId blocks entire server

Ubuntu 20.04

Webmin version 1.960 Virtualmin version 6.13

Using PHP-FPM we’d try FCGId for one site.
Server Configuration / Website Options

We should not have done that. The whole server was blocked. Apache wouldn’t restart.
Tried go back to PHP-FPM. No use.

Checked Services / PHP-FPM Configuration / Edit Configuration Manually
It was almost empty.
We had to manually rebuild that file, then Apache could start again.

Why did this happen? Should it not be possible to do such change?


It looks to me as an odd sporadic error. What you should do is to restart Apache manually:

systemctl restart apache2

So I did. Then I got Error. “Could not start Apache”

What error does it show if you run:

systemctl status apache2
systemctl restart apache2
systemctl status apache2

Tried many times at that time. Then I did this:

After that I didn’t dare to switch PHP-FPM to FCGId again.

Sorry I didn’t copy it. Just remember “Could not start Apache”

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.