Support for Ubuntu 18.04 LTS in and our apt repository

Howdy all,

I’ve just rolled out the first (version 6.0.11) with support for Ubuntu 18.04 LTS. I’ve also created a new virtualmin-bionic repository with 18.04 LTS binary packages.

This should be considered a beta release. Please test your use case thoroughly before counting on it in production! We always expect issues to be found when new distributions are released, because things change in subtle ways. Versions of underlying software changes, paths may change, default options might change, etc. In my testing of the most common installation scenarios, it seems to work well, but Virtualmin has a gazillion options and manages a bazillion moving parts, so surely y’all will find something borked once you start using it.

Known issues:

  • SQLite module has an incompatibility with newer Perl versions. Will be fixed with version 1.6 of the SQLite module rolling today or tomorrow.
  • More user testing needed!
  • New network configuration system is not yet supported by Webmin. If your system uses the old network scripts, you can use the installer today…but, if you’re using netplan (the new default), it is not yet supported. Jamie is working on it, but it is a huge amount of new code to be written, so it may be a few more days.

If you run into any bugs, please let me know in the issue tracker.



Edit 7/10/2018: Updated to specifically mention the netplan issue, which is ongoing. So, still beta. Read the whole thread and links for more info on the status of that, if you want to install on 18.04 today. You must use the old network configuration scripts for now.

New known issue on Ubuntu 18.04:

Ubuntu’s default network configuration system changed completely in 17.10 to something called netplan. I didn’t notice because the test systems I spun up at a virtual machine provider I frequently use had been configured to use the old network configuration system.

Jamie is planning to implement support for netplan in Webmin in the coming weeks. But, and this is a big but: This is a whole new service with it’s own configuration files, its own management tools, and its own way of doing things. It is not a minor juggling of config file locations or some new management tools stacked on top of the old thing. Thus, it’s gonna take some real work to support it. I do not know how long; Jamie can’t dig in until this weekend, so we won’t even know the scope of the work until then. Jamie is wicked fast, but even he is human, so I think an optimistic estimate for supporting netplan is at least a couple of weeks and probably longer.

So…that means if you want to install Virtualmin on Ubuntu 18.04 today, you’ll need to convert your system to using the old network configuration scripts. This isn’t hugely complicated from what I’ve found, but I haven’t tried it yet, so I dunno for sure. There have been several discussions about this change and how to revert it at Ask Ubuntu among other places. I’ll find a provider that has Ubuntu instances that use the new configuration in the next day or two (or make my own new image for Cloudmin and spin it up on one of our servers), so I can try it out and document how to change it.

Anyway, I wanted to get this out, since I finally sorted out today that all of the disparate bug reports I’ve gotten were actually this same problem, even though the reports were about a bunch of different services. (Folks didn’t notice that the installer bailed before it finished…fatal errors will exit the installer before completing the rest of the config…so you can’t ignore a fatal installer error. The system isn’t expected to be configured correctly after a fatal error during install.)

Thank you so much Joe, you folks are amazing awesome. I’ll stick to 16.04 in the meantime.

Inbox distro upgrades seem to also work. I had no issues with both my machines running Pro on 1 and the GPL version on the other.

FWIW, there are 2 versions of Ubuntu 18.04 server installer ISO. A new “live” version and an “alternate” old version. Unsure if the net config on each is different.
EDIT: just did 3 cloudmin KVM installs of 18.04. Using mini.iso, using live.iso, using alt.iso. All 3 default to netplan config in /etc/netplan/*.cfg. Only difference I saw in my quick install tests was the live.iso got an IPV6 automatically and didn’t ask for or care if it had IPV4.

I’d be happy to let you test with these KVMs, or an empty system.

There isn’t really anything to test until we’ve got netplan support in Webmin. The installer currently works (close to perfectly, as far as I can tell, though I’d still recommend testing a bit before putting into production) if the system is using the old method of configuring networks, and will not work if the system is using netplan.

So…we’re waiting on Jamie to have enough spare time to implement some netplan support in Webmin, and then I’ll make the installer aware of netplan. My part of it is small, and shouldn’t take more than a day or so, but Jamie’s part is big. It’s probably not so awful, since at least it uses a well-known existing config file format (YAML), so Jamie doesn’t have to write a new custom parser (though he’s good as heck at doing that, it’s still more work than just using a library), but he’ll still need to munge the data into data structures the Webmin network module understands so it can be presented in the UI and be interacted with by other modules, like Virtualmin.

Just to note that the installer has curl set up as so:

/usr/bin/curl -f -s -L -O

this needs the -k switch to get it past the invalid certificate warning on the script.

Otherwise, so far so good :slight_smile:

Hi all,

Is support for installing Ubuntu 18.04 LTS with imminent?

Trying to decide whether I should hold off for a few days or go with 16.4 now… would hate to find out would have installed 18.04 if I had just waited another day or two :slight_smile:


oh, FYI, it says on the script that 18.04 is supported… I’ll assume this thread is more up to date and that’s a leftover…

Yesteday I install Ubuntu 18.04 and latest Virtualmin. Installation was ok, but Network/DNS configuration can be done only manual. So we must wait for compliant Virtualmin version. Does anyone know date when it can be happen?

This is work in progress. See also

But progress seems to have stalled a bit.

It’s still beta and netplan is still unsupported. I changed the OS support list in the installer a little prematurely because I didn’t know about the netplan issue (my test instances at our VPS did not use netplan, so everything Just Worked in my testing).

Just a quick update on this:

Jamie is finishing up the new Webmin release with Netplan support as we speak, with expectation to roll it out within the next few hours (barring any problems).

Once that gets rolled out, I’ll do some testing and make any modifications we need to the install script and the virtualmin-config Net plugin.

Hopefully, y’all will be able to try it out before the end of the week, and it should be production-ready within a week or so (I assume any new OS needs some testing by real users before it’s really solid).

Awesome, thanks for the update!

Another update: Webmin 1.890 with netplan support is in the repos. I should be able to do some testing and make any necessary updates in the next day or two for Ubuntu 18.04 support.

Thanks, Joe!

Will Ubuntu 18.04 now be mentioned in the install script?

When it’s finished it will be. So, another day or two.

install script with LEMP bundle option on Ubuntu 18.04 LTS produces an installation that does not come back from a reboot. the host becomes unreachable.

When install completes, I connect via port 10000 and complete the wizard. the dashboard says a reboot is needed, so I reboot it and then the host becomes unreachable. I reinstalled Ubuntu 18.04 on the vps and ran the script again with the same result. I have not been able to locate the issue as of yet.

install with LAMP works and I was able to manually install nginx which produced a working server.

Let me know if anyone else can reproduce this problem.

I am having the same problem on a LEMP install on DigitalOcean, Ubuntu 18.04.1 as well. When install completes, I can’t even access port 10000 though. After rebooting, I can no longer access SSH remotely.

I faced a similar problem with EC2. I used LAMP with -m and after reboot I can’t access it anymore either through SSH or webmin.