SuiteCRM installation on Virtualmin

I tried to install v8 through v8.13 over the last few months and kept getting errors with permissions and non-functioning pages. Eventually, I was able to see that permissions had somehow been changed and that blocks SuiteCRM from working. I have it working about 75% but many features don’t work and it isn’t ready for use in my office. The SuiteCRM forum talks a lot about how permission errors are common and they seem to get changed when upgrades or installations occur.

I hired an expert in SuiteCRM earlier in the year who has hundreds of installations using WHM and cPanel and eventually today he told me that Virtualmin cannot work with SuiteCRM. My goal was to be able to log leads replying to my advertisements and followup for sales purposes. It isn’t good enough to use for the office and I am not believing that a Virtualmin domain cannot work. It makes no sense to me since SuiteCRM has millions of users but my error logs are cryptic or incomplete, php logs show only a few errors and after many weeks of trying I’ve stopped development. The expert contacted me to followup with switching to app to a WHM/cPanel and actually sounded displeased at my attempts to continue with Virtualmin. Here is a clip of today’s interaction.

SuitCRM has all kinds of error logs that report exactly what the problem is.

SuiteCRM 8 also utilizes the error console in chrome browser.

The installation also has a self check on upgrade and reports all errors on installation to the upgrade.log file.

What happens is your server AFTER install or upgrade your server assigns new permissions or ownerships to new files and cache files that are being created. Your server also blocks access to key files based on ownership and permission.

This is all clearly logged in the log files. The log files are also configurable on what type of errors to log and depending on the level of the error.

Virtualmin is horrendous! Just so happens I’m working with a client right now (against my better judgment) on Virtualmin. Fighting tons of permission issues, add a new field, crash the database, it’s brutal! We’ve had to restore twice already for no apparent reason. I runs out of memory, there’s no easy access to the database directly. I could go on but it’s been the most frustrating experience. As well, for some unknown reason it’s writing Gigabytes of MySQL log files that just about filled up all the disk capacity and crashed the server. Sorry, for the rant I’ve been fighting this for like two weeks now. Anything simple and normal in SuiteCRM causes Virtualmin to crash the whole thing.

My purpose for posting that quote is to ask who has installed SuiteCRM successfully, which version(S) and is there any reason why SuiteCRM would not work (except for my installation mistakes maybe). The consultant worked on it for two weeks and gave up. Appreciate comments and help to get it working. Thanks.

If hes a “expert” he is having trouble, sounds like its not suited the Virtualmin setup. Have you tried just using webmin or do you need virtualmin?
BTW I just did a quick search on the suitecrm forum and one guy on there install ok using a Debian 10 install. Maybe it the OS your using!!

I agree with @stefan1959 - that expert you hired may be a SuiteCRM expert but he is wrong about “Virtualmin cannot work with SuiteCRM”.

FWIW I have many clients who use SuiteCRM on their virtual servers on Virtualmin and use it with all the bells and whistles - email integration, plugins, integration with external IP BPX et al.

Please treat this message as confirmation that SuiteCRM does work with Virtualmin.

I have installed SuiteCRM v7 on Centos 8, then “ELevated” to Alma Linux 8 with no basic problems. I say it like that because my 2GB memory is not really sufficient for a production system and it can hang from time to time.
I also manage the server with Virtualmin GPL with all current updates applied.
I’m a relative novice at these things, but it seems the only thing that might affect a installed package like SuiteCRM is that Apache runs as the user account. I’ve never found this to be a problem if you have let Virtualmin manage the system from initial installation.
Since there is no Virtualmin install script for SuiteCRM there could be scope for permissions problems depending on which user acount you used to install it, but if that were the case I imagine there would be major problems that would probably not even let it start.

Thanks to all who viewed and took time reply. I believe part of my frustration was adopting V8 of the SuiteCRM instead of starting with the mature V7. I note V7 SuiteCRM is installable here at Virtualmin for Pro licensed users and I did not realize that as a GPL user.

I would have been further ahead to pay for the Pro Virtualmin, installed V7 using the script instead of wasting weeks on V8 myself plus my consultant fees.

@PeterP if you could sketch how you went about installing SuiteCRM v7 as a GPL user I would find that interesting to test. I don’t think it will be trivial to move by database from SuiteCRM v8 back to v7 but it might be the quickest way to use the app.

Thanks to all again.

This page has a step by step install commands for suitecrm version 7 or 8 on linux mint which is based on ubuntu.

These are my notes from installation. They are annotated versions of advice from others.
Some actions, like using Remi’s PHP may no longer be necessary, use your own judgement. And, of course the actual version numbers may no longer be valid.
I also found some useful advice at https://pgorod.github.io
Good luck!

1. Login with SSH as domain user <username>
2. Latest SuiteCRM package from https://suitecrm.com/download/
3. wget https://suitecrm.com/files/162/SuiteCRM-7.11/513/SuiteCRM-7.11.15.zip
4. Unzip SuiteCRM. This creates a “SuiteCRM” directory within your selected parent directory.

unzip SuiteCRM-7.11.15.zip
5. At this stage, you may wish to rename the default “SuiteCRM” directory.
mv SuiteCRM-7.11.15 SuiteCRM
6. Set the correct permissions on the SuiteCRM directory (Linux):
cd SuiteCRM
chown -R www-data:www-data . Not for Virtualmin, Apache runs as user
chmod -R 755 .
chmod -R 775 cache custom modules themes data upload
chmod 775 config_override.php 2>/dev/null
7. Install PHP with ZIP enabled
dnf -y install yum-utils
dnf -y install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm Not for Virtualmin, already installed
dnf -y install https://rpms.remirepo.net/enterprise/remi-release-8.rpm
Dnf module reset php
dnf module install php:remi-7.3
yum -y install wget php php-{pear,cgi,common,curl,mbstring,gd,mysqlnd,gettext,bcmath,json,xml,fpm,intl,zip,imap}
8. To confirm the php version installed, use the command php -v
9. Increase php timeout and max file upload size: (Webmin >Others>PHP Configuration>Resource Limits
nano /etc/php.ini
upload_max_filesize = 20M
max_execution_time = 120

.

From <https://computingforgeeks.com/how-to-install-suitecrm-on-centos-linux/> 

To Setup Crontab
In order to run SuiteCRM Schedulers, edit your web server user's crontab file with this command:
sudo crontab -e -u <username>
... and add the following line to the crontab file:
*    *    *    *    *     cd /home/<username>/public_html/SuiteCRM; php -f cron.php > /dev/null 2>&1 
You should do this only after the installation is concluded. 

From <https://<mydomain>/SuiteCRM/install.php> 


Command line update
Download update file to main directory e.g. public_html/SuiteCRM
From the main directory, using an account with write privileges, e.g. the  <username> you installed with.
./vendor/bin/robo upgrade:suite SuiteCRM-Upgrade-7.11.x-to-7.11.18.zip upgradeLog.log . admin1

Note “admin1” above is the SuiteCRM username.

Thanks Chris_C