Suggested DNS Records Disapeared

|Ubuntu 22.04.02 |
|Webmin version 2.0.21 |
| virtualmin version: 7.7.gpl-3|

I used to copy all the suggested dns records to cloudflare but it seems the latest version does not display them.

As you can see now it has only one record

Mine its like that too. I use GPL on alma 8.8

Using Rocky9 works fine, maybe a OS bug.
So you only see DKIM line?

Also broken on RHEL 9.2 Pro, but OK on GPL

Exactly, only dkim

Can @staff please have a look at this?

I wasn’t able to re-produce this… are you running Virtualmin 7.7-3 ?

Yes 7.7.gpl-3 and all updates have been installed.

I used to host dns on my virtualmin, but decided to use cloudflare and disabled bind following @tpnsolutions instructions on this post: Question about disabling BIND - #2 by tpnsolutions

After doing that, only DKIM apeared in the suggested dns records.

RHEL 9.2, Webmin 2.021, Virtualmin 7.7 Pro (same but GPL still works OK).

If you re enable it in Features and Plugins does Suggested work, that how I have it even though non of my Virtualservers use the dns service.

Didnt work, only DKIM its appearing. @stefan1959

Any news on this? I still cant see the suggested DNS Records.

I have this also, only happened when the DKIM was added to the mix…

@Jamie have you tried to reproduce this after enabling dkim?

its now gone.

1 Like

Ok that’s odd … are you using Virtualmin’s built-in Cloudflare integration?

I have just enabled and disabled the problem domain in CloudFlare to try and reproduce the issue, and NOW the thing shows all the records. The one thing i did before was to remove the domain from Cloudflare so i could put it back where how it was before, however, i removed it from cloudflare BEFORE removing DNS from the VM, it threw a red error and would not remove the DNS facility. I manually re-added to cloudflare, deleted the DNS facility (it worked this time and deleted records on cloudflare) then i removed the domain from cloudflare and switched back to the old off-site DNS servers. When i went back to the suggested DNS records to check i had something to show for my efforts - it was showing all the suggested records… SO for the only domain that is not now off-site it is now working as expected… i am happy but also as you could see from the grab i sent you it was not doing what was expected… And also i meant to put this into a DM…

Yes, the virtualmin <> cloudflare integration is fantastic.

Im not using it, GPL here