Suexecusergroup error on starting apache


Starting httpd2: Syntax error on line 233 of /etc/httpd/conf/httpd2.conf:
Invalid command ‘SuexecUserGroup’, perhaps mis-spelled or defined by a module not included in the server configuration


This is the error i get when trying to start Apache…
I have absolutely no clue on were to start to fix this…
I saw a possible solution, cant recall what tho…, but that didnt work. It only gave me a unknown command error…

What can i do to fix this and get apache running?

I run Mandriva on a VPS server.

Install apache-mod_suexec

> install apache-mod_suexec
install: too few arguments
Try `install --help’ for more information.

Ive been lookin for in the help, but that doesnt give me more idea’s also… Ive been trying most of the commands and still no luck.

Cant find a edit button…

When i select the mod suexec in the reconfigure known modules, it will not remember it…

I found a solution finally… I used search APT in my webmin install, and instaleld suexec that way.

Thanks for the help.

Hey Leon,

Mandriva uses URPMI for package management. So you would use:

urpmi apache-mod_suexec

The full deps list we use during installation of Virtualmin Professional on Mandriva is:

apache2 apache2-common apache2-manual apache2-metuxmpm apache2-mod_dav apache2-mod_ldap apache2-mod_perl apache2-mod_php apache2-mod_proxy apache2-mod_suexec apache2-mod_ssl apache2-modules apache2-peruser apache2-worker clamav clamav-db clamd bind bind-utils caching-nameserver cyrus-sasl postfix postfix-ldap postgresql postgresql-contrib postgresql-docs postgresql-pl postgresql-plperl postgresql-server proftpd proftpd-anonymous quota perl-Net_SSLeay perl-DBI perl-DBD-Pg perl-DBD-mysql spamassassin perl-Mail-SpamAssassin mailman subversion subversion-server MySQL MySQL-common MySQL-client openssl ruby usermin webmin webalizer awstats dovecot

This, I believe gives you all the bits you need, though we don’t have a lot of Mandriva users to give us confirmation of that through real world testing.

I don’t remember if you have to do anything special on Mandriva to enable the suexec module. On most of our systems, installing the module enables it, but it does have to be enabled manually on SUSE, so it might need some extra work on Mandriva, too. As soon as I get caught up, I’ll be doing some building and testing for the newest version of Mandriva and the x86_64 architecture…I should be a bit more familiar with the platform by the time that is done.

Joe Mandriva 2007 uses apache2 as the default now. There is no apache2 mods just apache. Apache 1.33 is called apache1 in mandriva 2007 and 2006.

And Leon… DO NOT USE APT-GET in mandriva. It will break your system.

Use urpmi in the console.


I use Mandriva exclusively here. Both 2006 and 2007. If you need anything let me know.

Second in 2006 & 2007 its only apache_mod_* since apache 2.X is the default. Apache 1.X is provide still but you have to call the rpms with the apache1* name instead.

As for anything special for mod_suexec nothing special is needed. Just install it and everything works just fine. There are some mods that will break the httpd -t and cause a warning when testing the conf and vhost files. If you need to know which ones those are let me know.

I also suggest that you join the Mandriva forum at if you haven’t already and post for Mandriva specific help there. You are a real newbie so I would start there.

Dang a load of reply’s :smiley:

When im waking up tomorrow after work i will make sure to read good through all of them…

I still need to get the php mod and perl mod in there so i will try to uprmi (iirc) to do it right.

Again thanks guys.

The apt-get didnt break anything for so far as i can see… Still have to upload some pages and see what happens.
So far i like the webmin / virtualmin / usermin combo.
If i ever reinstall my vds i will for sure use it again… It make smy life so much easyer :smiley:

Hi, same problem over here, apache2 is not working out of the box? very strange.


:/# apt-get install apache-mod_suexec
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package apache-mod_suexec

Webmin Package Installer:

Installing package(s) with command apt-get -y install apache2-suexec ..

Reading package lists...
Building dependency tree...
Reading state information...
Package apache2-suexec is a virtual package provided by:
  apache2-suexec-pristine 2.4.38-3+deb10u3
  apache2-suexec-custom 2.4.38-3+deb10u3

E: Package 'apache2-suexec' has no installation candidate

System Info

:/# uname -a
Linux ..... 4.19.0-8-amd64 #1 SMP Debian 4.19.98-1 (2020-01-26) x86_64 GNU/Linux

Webmin version 1.941
Virtualmin version 6.09
Operating system Debian Linux 10

Thanks in advance