suexec configured to run under /var/www ...

This whole install have been nothing but problematic I was hoping that it was a faulty install that was causing my previous mail, and cgi problems. I even used webmin to install all modules during the testing process.

That’s not the way to install a full Virtualmin stack. Installing Webmin modules does nothing to the underlying system–it simply can’t. Webmin module packages don’t have that kind of capability–they’re just tarballs (though Webmin does do some dependency resolution against other Webmin modules and such).

There is an install script for Virtualmin found on the download page here at It does a complete install of all dependencies (like Apache, BIND, Postfix, etc.) and it configures them appropriately for use with Virtualmin. Installing and configuring manually is certainly possible…but it’s not something I’d suggest unless you’re a pretty serious Linux nerd.

It is the public version so I guess that is a possible reason why.

The install script is available for both Virtualmin GPL and Virtualmin Professional. There is quite a bit of documentation about installing Virtualmin here:,automatic_virtualmin_installation/

I am not talking about the Webmin module for Apache. That is in the base install of webmin. Modules only function, I know, is to interact with the programs setup files, to install them if they are not installed, or reconfigure to see installations that are different from the norm. I had to do that routinely with setting up Apchie2 to work with Webmin.

What I am referring to is the fallowing.

When you go to a Webmin module, if the program the module is supposed to control is not installed, it will ask if you wish to install the program. The module calls apt-get and installs the program. It will usually move the module from unused to the appropriate category.

The link to the module is usually given on the failed program check dialog. Not the "The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin base directory is /home. CGI and PHP scripts run as domain owners will not be executed." error though.

As for the install script it will not work on my system. Complains that my os is not supported. So that option is not in the works unless it has an override to allow installation on a Debian system anyway.


script failed, incorrectly reported os

That’d be something I’d want to know about. If you really are running a supported OS version, it should work…if it doesn’t, I want to fix it. Give me more details! :wink:

Well now it is totally out.

Try again. from the fresh install.

all attempts are a bust so far. I will try again.

This time I will update and upgrade the install with apt-get before any attempt to install webmin or virtualmin.

What exactly should

/etc/ issue and Debian_version look like for the setup script to do its job?


What details do you need?

Well! I got the script to work finally!

It did not like they way that the redwood debian_version was set up. put 4.0 in and it ran.

Failed on first round.

Had to remove my previous attempt to install virtualmin-base did that with apt-get remove and the script ran to completion. Now I will test the install.


First round of testing showed that MySQL not install Doing so now

quick check of mysql showed that it was installed.

Rechecking webmin config now shows that it is up an running.

Now to install my site backups.

Hummmm Seems that non of the backups I had beem makeing are backups. webmin says

Restore failed : The specified source does not contain any domains, or is not a Virtualmin backup

When one looks in the file there is all the directories and data in the domain.

Why is webmin not seeing these backups as backups?

It seems that the file selection dialog is not working right. It requres you to select a file not a direcotry. I removed the filename and it worked.

for most I should say the key one it failed on the tar file for the home directory and stopped.

getting closer

I’m not sure I understand what problem you’re having? What file selection dialog? What are you doing, and what is happening that isn’t right (and is there an actual error message you can give us)?

I am attempting to restore the backups I made to my server this morning. When you click on ftp or upload file it gives the file field to be filled in with a url to the file. If you use the browse or … button it expects a file not a directory to return you to the brower and fill in the the box for you.

Selecting any of the files in the restore directory ie and it will tell you that it is not a valid file I copied the error in an earlier post.

Delete the file name and submit and virtualmin reads the directory and returns you a list of the domains you wish to restore.

I have gotten one to restore but not all The most important one is reporting an error in the tar file for the home dir and stopping

I am now attempting another round of restoring.

Now it is complaining

Restore failed : DBI connect failed : Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)

I will try to check that.

MySQL was not started

started it and it continued stopping at failed to create postgress Alias file

I back paged removed the domains that install and started again.

It seems that the restore fails randomly Mostly with tar file failure. removing installed domain seems to get on to the next.

unfortunately the user home directories did not get restored fortunately the are in my daily incremental though I will lose several hours of mail. I will look again into the full backup I did earlier today

I just tried to restore from directory on my local box that I do incremental restores to. The file selection dialog will only allow a specific file and NOT let you select the dir or let you edit the url. Update fails stating that the file is not a valid restore file.

How do you restore mail from this incremental backups?

How can I Disable suexec in Virtualmin??

ubuntu8.04 lt whatever it is this is a fresh install and get this error trying to disable suexec. also install wat done using the intaller of pro that i have linked from my perchase…

Failed to save server template : PHP scripts cannot be run as the domain owner unless suexec is enabled

seen refrences to virtualmin`s apache module but cant seem to find it.

You can enable suexec by going into System Settings -> Server Templates -> Default Template -> Apache Website, and make sure "Automatically add appropriate SuExec directive" is set to "yes".

I am having a similar problem too, I have tried to install the apache module via the "webmin" -> "webmin configuration" -> "webmin modules: -> "standard module from

it installed successfully and I restarted apache

then I tell it to re-check config

and I get this:

Mail server Postfix is installed and configured.

The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin base directory is /home. CGI and PHP scripts run as domain owners will not be executed.

… your system is not ready for use by Virtualmin.

I do not know what to do beyond this.
Can you help me.

Yeah, the problem is that you have your distributions version of Apache installed, rather than the Virtualmin version. Virtualmin’s version has suexec pointed at the correct location.

Your options are to either install the Apache packages from Virtualmin’s repository, or to go into the Apache Website section of the server templates and disable suexec support if you don’t need it.