Suddenly unable to connect to webmin

SYSTEM INFORMATION B
OS type and version Debian GNU/Linux 10 (buster)
Webmin version 2.105
I am unable to access webmin from my PC with the ipadress:10000 this happened suddenly one day it was working fine, and the next it was unable to connect. I have restarted webmin and rebooted my server.
webmin status is
webmin.service - Webmin server daemon

I am unable to access webmin from my PC with the ipadress:10000 this happened suddenly one day it was working fine, and the next dit was unable to connect. I have restarted webmin and rebooted my server.
webmin status is
webmin.service - Webmin server daemon

Active: active (running) since Wed 2024-05-22 15:35:14 BST; 23min ago

I’ve tried connecting different browsers firefox and Chrome, and tried disabling my AVG antivirus but nothing helps. Has anyone got any idea? The next step is probably to reinstall webmin

Don’t do it! This isn’t Windows 3.11.

I think you’re being blocked by Fail2Ban. You can check that by running:

fail2ban-client status webmin-auth

and unban an IP by running:

fail2ban-client set webmin-auth unbanip 10.211.55.2

Additionally, it’s always recommended to check the /var/webmin/miniserv.error log file.

I’m not sure I had fail2bn installed. fail2ban-client wasn’t found. I installed fail2ban but there was no webmin-auth file: “Sorry but the jail ‘webmin-auth’ does not exist”.
The miniserv.error file doesn’t contain much.
tail /var/webmin/miniserv.error
[22/May/2024:15:32:01 +0100] IPv6 support enabled
[22/May/2024:15:32:01 +0100] Using MD5 module Digest::MD5
[22/May/2024:15:32:01 +0100] Using SHA512 module Crypt::SHA
[22/May/2024:15:32:01 +0100] PAM authentication enabled
[22/May/2024:15:35:11 +0100] Shutting down
[22/May/2024:15:35:14 +0100] miniserv.pl started
[22/May/2024:15:35:14 +0100] IPv6 support enabled
[22/May/2024:15:35:14 +0100] Using MD5 module Digest::MD5
[22/May/2024:15:35:14 +0100] Using SHA512 module Crypt::SHA
[22/May/2024:15:35:14 +0100] PAM authentication enabled

To rule this out, are you accessing through ssl by using the https? https://ipaddress:10000
I know some people make a mistake and try to access through http.

Just a thought,

Yes I’ve tried both
https://46.43.15.187:10000/ if you want to give it a go this would rule in or out a blacklisted ip address

What firewall are you using? You may need to open the port?

I’m not 100% sure of the firewall I was using iptables and I’m pretty sure I have used fail2ban but after my last upgrade I can’t remember what was used. I can’t figure out why it worked one day but not the next. I had made no system changes or upgrades. There may have been a new version of webmin though.

You can run the following commands and what ever comes back with a status will let you know if they are installed or not.

sudo ufw status
sudo firewall-cmd --state

Do you have just Webmin installed or is this Webmin and Virtualmin?

1 Like

sudo firewall-cmd --list-all-zones

I would also check the status of the webmin service just to be sure that webmin has not failed without writing anything to the miniserv log, rule out the easiest things before you start digging into the firewall. You could just stop the firewall service as the OP is unsure wether they are using firewalld or iptables. But it is odd that webmin has been running fine for a while then suddenly stops working and tbf it does sound like some ip rule has been set.

I’m using webmin I didn’t have ufw installed, I installed it and get Status: inactive
sudo firewall-cmd: command not found

I was actually in webmin and left the computer in sleep mode. Next day (Tuesday) it wasn’t working.

webmin is up and running Loaded: loaded (/lib/systemd/system/webmin.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2024-05-22 15:35:14 BST; 4h 32min ago
Main PID: 6636 (miniserv.pl)
Tasks: 1 (limit: 2335)
Memory: 36.5M
C

May 22 15:35:11 dinglesgames.default.paulsingleton.bv.iomart.io systemd[1]: Starting Webmin server daemon…
May 22 15:35:12 dinglesgames.default.paulsingleton.bv.iomart.io
There is an error "
am_unix(webmin:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost= user=root"

If you installed ufw you can activate it with command below and enable port for webmin.

sudo ufw enable
sudo ufw allow 10000

Your computer or the server?

My PC, the server is always on I rent it.

sudo ufw enable
sudo ufw allow 10000
I’ve done this but no luck

Status: active

To Action From


10000 ALLOW Anywhere
10000 (v6) ALLOW Anywhere (v6)

So I guess your pc is behind a domestic router ? If it is It’s worth a look that the router has not had a firmware upgrade and for some reason disabled some of It’s internal firewall rules or perhaps the router no longer allows port 10000 through the firewall

turn off firewall and see if it works