Stuck on Virtualmin setup

I’ve created a VirtualMin (open source) setup with Ubuntu 12.04 as explained in this tutorial: and ran the Django install script.

After this I’ve gotten stuck. On the Apache Webmin page I see that the IP address of the virtual server is, port 80, but I get the message, “Firefox can’t establish a connection to the server at” Clicking the domain name for the site gave me the same result. Am I going to the wrong URL, or is there some problem with the configuration of the virtual server?


It looks like that page goes about installing Virtualmin the hard way.

Our recommendation isn’t to perform a manual installation like that, but to instead install a fresh version of Ubuntu LTS (either 10.04 or 12.04), and then to use the script in the Downloads area to perform the installation and configuration of Virtualmin.

I’m not sure if that’s the reason for the error you’re getting – but with a manual install, it’s difficult to know how your system is setup, and you may save yourself a lot of trouble by using the automated install.

Is it possible to start over with a fresh install?


Yes, I’m also getting the message, “The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin virtual server home directory is /home. CGI and PHP scripts run as domain owners will not be executed,” so I think there are problems with the configuration. I wll try installing from scratch and see how it goes.


The error you’re seeing means that suexec hadn’t been configured to run out of /home, where Virtualmin places it’s websites.

That will happen for you automatically when using the to perform an install.

Just make sure you’re using a supported distro – any of the Ubuntu LTS releases would be just fine, such as Ubuntu 12.04.


So now when I run sh I get the message, “Serial number @SERIAL@ contains invalid characters.”

Hmm, I haven’t been able to reproduce that problem… where did you download the script from?

One thing you could try is to download it again, using the following link:

What you could do is log onto your server as root over SSH, and run this command:


And then you can run it with this command:


Thank you! The setup script seems to be working.

After downloading the current GPL script with wget to a fresh Ubuntu 12.04, I am also getting the ser# error. It looks like is requiring a ser# parameter to execute. Specifically, the error is:

“Serial number @SERIAL@ contains invalid characters.”

Are you sure you downloaded the correct script from the right place? I just took a look at the install script’s code, and the relevant part is as follows:

SERIAL=GPL KEY=GPL VER=1.0.9 echo "$SERIAL" | grep "[^a-z^A-Z^0-9]" && echo "Serial number $SERIAL contains invalid characters." && exit

According to this code, it is impossible that the “error message and exit” are executed, except your echo or grep command behave differently than on a usual Ubuntu. :slight_smile:

Can you verify that the install script you downloaded contains that code bit in lines 66 to 69?

That was indeed the problem. I had the pro script.

However, I’m more than a little puzzzled because, as I wrote the above query/comment, I was still in an SSH session and specifically rolled back to review the sudo wget command I had used to retrieve the file, and could swear it said …/gpl/scripts/ In fact, I’m even quite sure I copied the wget from the comment at the bottom of which clearly calls the gpl version.

Obviously, somewhere, somehow it got screwed up but I’ve no idea how. I’ve poured over the entire Virtualmin site looking for some other wget download command I might have used that was wrong, but… no “joy”. Sio I be humbled again, though I wish I knew how it happened. Oh well.

In any case, thanks for clarifying the diff between the two different scripts, as I might not have figured it out so easily otherwise. Onward.

I faced a similar issue. At the command, it was complaining about invalid characters as serial no. When I actually checked the download link I used, the “/scripts” was missing. i.e. Instead of , I had used and this seems to have downloaded the pro version.