Strange error "File not found" with PHP FPM on Centos 8 Stream

SYSTEM INFORMATION
OS type and version: CENTOS 8 STREAM
Webmin version: 1.981
Virtualmin version: 6.0
Related products version: PHP 7.3 or PHP 7.4 or another

Hello,
I have strange behavior on a fresh install of Virtualmin with PHP FPM.
Sometimes when I create domains the website doesn’t work. The configuration is the same however as the others, same version of PHP. But I got an error when I load the website: “file not found”.
Looking at the logs more closely I see:
AH01071: Got error ‘Primary script unknown \ n’
Where could this error come from?
Thank you

Hello,

I have same problem. All my virtual server accounts are working correctly. But just one account give same error. Moreover, the same php files are working well in another account.

The only error: AH01071: Got error ‘Primary script unknown \ n’

Did you find a solution to this problem?

Thanks.

By the way in this account html files and other options working well, just php not working.

PHP-FPM?

FPM Pool files sockets…?

phpinfo tested in dieser domains selbe?

also ein .php Datei dort den phpinfo…

resim

Yes, same error “File not found.”

Can’t help using other.

But check or do search (forum or web) on fpm pools or sockets / ports

That out of php-fpm-v is also the php version and set used for that vserver/domain ?

Also check if that vserver / user has php active in settinsg for that server configuration

Dear jotst,

I changed the definition of
“SetHandler proxy:fcgi://localhost:8004”
in the etc/httpd/conf/httpd.conf file relevant fields to
“SetHandler proxy:fcgi://127.0.0.1:8004”.

It’s fixed now.

Thank you.

Yup could be a old kind of bug virtualmin i am not sure.

There was a problem, conflicting or not set value there. as i remember.

Or network hosting after reboot the resolv.conf overwrite is also one…

Are you working under Jail ? If yes, disable Jail et re-enable it (under “User restrictions options > Others restrictions” under domain) to fix problem.