Still... "Dashboard displays Dovecot not running but it is"

https://forum.virtualmin.com/t/dashboard-displays-dovecot-not-running-but-it-is/104732

Before restarting server because of kernel update “Linux 3.10.0-1127.10.1.el7.x86_64” I saw again in Dashboard Dovecot not running despite no user complains about mail server.

I keep seeing reports along these lines, but I don’t know how to resolve them. Webmin is just checking whether the service is running using systemctl status dovecot. We don’t have any control over systemd, and something seems off about dovecot in the way it interacts with systemd, lately.

I’ll try googling some more to see if there is any discussion of this problem in the wider world. I think any fixes will need to happen upstream of us (either in dovecot or the systemd service file being used on the distros where this happens), though.

Hi Joe,
I see Dovecot is again “stopped” but running…

I ran it now:

That happened yesterday (1day 1h ago)

tailf /var/log/maillog | grep dovecot is displaying pop3 and imap logins correctly 

System uptime 2 days, 9 hours, 22 minutes
2 days ago I restarted the server because a kernel update.

service dovecot restart
Redirecting to /bin/systemctl restart dovecot.service
Job for dovecot.service failed because the control process exited with error code. See “systemctl status dovecot.service” and “journalctl -xe” for details.

systemctl status dovecot.service
● dovecot.service - Dovecot IMAP/POP3 email server

  • Loaded: loaded (/usr/lib/systemd/system/dovecot.service; enabled; vendor preset: disabled)*
  • Active: failed (Result: exit-code) since mar 2020-06-09 21:25:53 -03; 8min ago*
  • Docs: man:dovecot(1)*
    
  •       http://wiki2.dovecot.org/*
    
  • Process: 31079 ExecStop=/usr/bin/doveadm stop (code=exited, status=75)*
  • Process: 25384 ExecStart=/usr/sbin/dovecot (code=exited, status=89)*
  • Process: 25381 ExecStartPre=/usr/sbin/portrelease dovecot (code=exited, status=0/SUCCESS)*
  • Process: 25373 ExecStartPre=/usr/libexec/dovecot/prestartscript (code=exited, status=0/SUCCESS)*
  • Main PID: 1094 (code=exited, status=0/SUCCESS)*

jun 09 21:25:51 host.hostname.com systemd[1]: Starting Dovecot IMAP/POP3 email server…
jun 09 21:25:53 host.hostname.com dovecot[25384]: Fatal: Dovecot is already running? Socket already exists: /var/ru…login
jun 09 21:25:53 host.hostname.com dovecot[25384]: master: Fatal: Dovecot is already running? Socket already exists:…login
jun 09 21:25:53 host.hostname.com systemd[1]: dovecot.service: control process exited, code=exited status=89
jun 09 21:25:53 host.hostname.com systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
jun 09 21:25:53 host.hostname.com systemd[1]: Unit dovecot.service entered failed state.
jun 09 21:25:53 host.hostname.com systemd[1]: dovecot.service failed.
Hint: Some lines were ellipsized, use -l to show in full.

I pkill -9 dovecot and then started the service

Thank you

Today morning I executed

 /usr/bin/pkill -9 dovecot
 /bin/systemctl start dovecot.service

And after some hours:

There are several threads about this, so I’m not going to repeat those conversations, but we think we’ve fixed it in the next release. If I can convince Ilia and Jamie to stop making changes for a couple days, we can get it rolled out.

1 Like