SSL via SNI: it works but still get [warn] RSA server certificate CommonName (CN) `' does NOT match server name!?


I’m using https via SNI for a virtual host.
Everything seems to work but I still get plenty of these in Apache error logs:

[warn] RSA server certificate CommonName (CN) `’ does NOT match server name!?

Is this normal?
Is there a way to get rid of these warnings?



What’s the actual server name? Is it “”? A certificate does not match subdomains, except it’s a wildcard certificate. That might be the reason, I haven’t worked with SNI myself yet.


I make use of SNI for all my certs lately, and have never run into any issues with errors. The only reason I can think of is the server doesn’t have the cert installed correctly, or your browser needs to have it’s cache cleared.

*** I’ve run into situations where the latter point was all to common. If you went to the page prior to installing the cert, you’ll need to often clear the cache so that it recognizes that the cert has been installed. ***

Outside those suggestions, if you provide us the actual domain we’d be able to diagnose things a bit more closely.

Best Regards, Peter Knowles TPN Solutions

Phone: 604-229-0715 (new)
Skype: tpnsupport