SSL Stunnel setup issue: ERROR — DOCUMENT FOLLOWS This web server is running in SSL mode

SYSTEM INFORMATION
OS type and version Ubuntu 22.10
Webmin version 2.020

Hi - I’m new to webmin (great program!) and am trying to use SSL. I set it up per these
instructions: Using SSL with Webmin.
When I try logging in at server:10001, I get an error and redirecting to the server:10000, here:

ERROR — DOCUMENT FOLLOWS

This web server is running in SSL mode. Trying to redirect to https://server:10000/ instead …

Redirecting there says “not secure”
I am using let’s encrypt but have set up webmin to us it’s own private key.
What am I missing?

Thanks

(all web search results say to turn off SSL in webmin - which is just wrong)

1 Like

I think it would be easier if you use Virtualmin on a Clean OS. It installs the Lets Encrypt certificates during the post install plus you got all the benefits of Virtualmin.
https://www.virtualmin.com/documentation/installation/automated/

Thanks. A few of things:

  • So I was really asking about webmin - not Virtualmin. I followed the instructions and no love.
  • I did look at Virtualmin and there are a couple of issues. The install script wants a clean OS and does not support Ubuntu 22.10, and there is no WAY I’m going to replicate my entire server(s) just to run Virtualmin.

Thanks for your response - but I would still like know why the steps given are not working for me.

Regards.

Looking at those docs, they really old.
" if you enable SSL support in Webmin, your browser must also support SSL (such as Netscape and IE). "
Did you see this Let's Encrypt - Webmin Documentation

@hap,

Can you send a screenshot from your browser showing details about the “certificate” when you navigate to “https://domain.com:10000”?

By default Webmin has a “self-signed” certificate, which is NOT recognized by the browser. It’s still secure, but will cause error like messages to appear in the browser.

Ah - that would be the major issue - the cert is self signed and the browser is warning it does not recognized the signing authority.
(oddly, I’ve not used self-sighed certs before).
All my web pages and application use letsencrypt, apache2 virtual domains and FQDNs.This works mail, zoneminder, nextcloud, etc. etc.
I’ll have to research using webmin with letsencrypt

Thanks.

Then why the hell are you trying to get Webmin to request a new cert? You already have a cert! Use it for Webmin, too!

I never said I was trying to get a new cert.
I am indeed wanting to use my own cert file. However all references I find point to getting new keys or using a private key.
To use my own cert, I have tried going to:
Webmin->Webmin Configuration->SSL Encryption->SSL Settings->Configuration File
and selected “Separate File” and pointed that to /etc/letsencrypt/live/domain/xxx.pem
This does not work. I wouldn’t be asking if I were an expert!

So how do I use my own cert?

Oh - and @tpnsolutions: the browser states cert for domain.org is valid, and cert for domain.org:10000 is not valid, and shows a different fingerprint - presumably because it is using the self-signed key.

Thanks for any help.

Thanks for the tips, guys.
My issue was that I did not specify a seperate file under:
Webmin->Webmin Configuration->SSL Encryption->SSL Settings->Private key file
Silly.
Works now.

Regards

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.