SSL request fails with the error "Let's Encrypt: request failed : Web-based validation failed : Failed to request certificate"

Hi All

I'm incurring in this problem since some recent OS update (I presume, because I recently updated Centos from 7.6 to 7.7...).
I have some Virtualhosts for WordPress multisite, each virtual host is configured with a main domain address and many doimain aliases.
This worked normally up to the end of September: but now I have some production machines facing those important issues!!
Erros are random and not always the same ones, this let me think the problem is somewhere I can't understand.

The most frequenbt error is this one:

Traceback (most recent call last):

File “/usr/libexec/webmin/webmin/”, line 250, in


File “/usr/libexec/webmin/webmin/”, line 246, in main

signed_crt = get_crt(args.account_key, args.csr, args.acme_dir, args.dns_hook, args.cleanup_hook, log=LOGGER,

File “/usr/libexec/webmin/webmin/”, line 131, in get_crt

log.error(“Error requesting challenges: {0}”.format(extract_detail(result)))

File “/usr/libexec/webmin/webmin/”, line 25, in extract_detail

rv = json.loads(result.decode(‘utf8’))

File “/usr/lib64/python2.7/json/”, line 338, in loads

return _default_decoder.decode(s)

File “/usr/lib64/python2.7/json/”, line 366, in decode

obj, end = self.raw_decode(s, idx=_w(s, 0).end())

File “/usr/lib64/python2.7/json/”, line 384, in raw_decode

raise ValueError(“No JSON object could be decoded”)

ValueError: No JSON object could be decoded

I’m running some VMs using CentOS Linux 7.7.1908 and latest 1.930 webmin/ 6.07 virtualmin, on ESXi 6.5

I have searched the forum, and tried to generate self signed certs before requesting Let’s Encrypt ones, it doesn’t solve the problem (up to one month ago it was normally working, and SSL were applied with no assle…)

Is there someone still running CentOS 7.6 and confirming that SSL works without issues in the same conditions?

Any hint to fix urgently the issue?

Thank you all in advance


Don’t know this is also >

And this. .

And probably some more, You could open a ticket if License?

Or buy tickets for payed support.

Some links to commits webmin virtualmin.

I askes before if webmin virtualmin works supported on centos 7.7 it shoulld i also mentioned Python version changes in that CENTOS while 2.x is almost EOL

The webmin script itself:

Some links to depricated stuff CENTOS.