SSL Renewal failed due to Web-based validation failed DNS-based validation failed

SYSTEM INFORMATION
OS type and version Debian Linux 12
Webmin version 2.105
Virtualmin version 7.9.0
Related packages Latest updates

image

Hello…
I hope to solve a problem

Ignore the DNS validation failure. That can only ever work if Virtualmin is managing DNS for this zone (and if Virtualmin is not managing DNS for this zone, you should turn off the DNS feature for this domain, so Virtualmin doesn’t think it can do things it can’t do, like DNS validation).

The web validation error is always the same three problems (something DNS, something with proxy/redirects, or “the wrong site shows up” config problem). Search the forum for that error (the web validation error). You’ll find dozens, maybe hundreds of posts, where I explain those three things.

Hello Dear

Problem solved by me

Go to SSL Certificate
To CA Certificate > Select None needed
Save

And then Go to Let’s Encrypt
Select Request Certificate

And check with cloudflare if there are any contraindications

Problem solved :blush:

Renewal of Lets Encrypt was a problem - not renewing -Webbased validation failed -for few of my sites for very long. Because it is not SSL site -no https:// works- The front side also is showing up not in orderly manner. It looked like children puzzle, meaning no template nor theme was working. Because the chrome browser thinks it as http:// site. But some of the sites in the same server it is automatically renewed.

What I found out?

Only in Some of the Larvael/Codeigniter/other php sites this problem occurred . May be those apps dont allow writing any directory even if it is above public_html. I tried everything - but one trick whether it has relevance or not worked for me.

I clicked file manager.
I created a backup folder in the public_html folder
I cut all the files and folders except backup folder and pasted the cut folders and files in backup.
I created an index.html file in public_html. Just wrote a word or two in the file.
Now public_html folder has only index.html that we just now created and the backup folder.
I went back to issue letsencrypt certificate.
It worked like a charm. The site was issued letsencrypt certificate.

Now I went back to the file manager and went to public_html folder. Deleted the index.html file that I created before. Then I cut all the files and folders in the backup folder and pasted them in the public_html folder.

The site worked perfectly

The description of your solution means you had an .htaccess file that was preventing access to the .well-known directory. Usually either a proxy or redirect rule. Those always have to exclude .well-known, if you want a Let’s Encrypt certificate (a variety of other stuff uses .well-known, but if you didn’t know about it, you’re probably not using anything that does).

keep in mind your Lets Encrypt certificate is only good for 90 days :grinning:

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.