SSL Renew Certificate Error = PLEASE HELP

OS type and version CentOS Linux 7.9.2009
Webmin version 2.101
Usermin version 2.001
Virtualmin version 7.7
Theme version 21.04

I have tries the Lets Encrypt forum and was told to try get help on virtualmin for this

I,m wrecking my brains out on this - just can’t seem to get a certificate even renewal is failing - I’ve tried both Please bear with me on this as I’m not very technical - Hope someone out there can help

My domain is:

I ran this command: Lets Encrypt Request Certificate

It produced this output:
Requesting a certificate for , from Let’s Encrypt …
… request failed : Web-based validation failed :

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Starting new HTTPS connection (1):
Renewing an existing certificate for and
Reusing existing private key from /etc/letsencrypt/live/
Performing the following challenges:
http-01 challenge for
http-01 challenge for
Using the webroot path /home/priyaexc/public_html for all unmatched domains.
Waiting for verification…
Challenge failed for domain
Challenge failed for domain
http-01 challenge for
http-01 challenge for
Cleaning up challenges
Some challenges have failed.

Is there a way to completley do a fresh new SSL request? delete all the certificates keys etc and start fresh? I have done this before but forgot how to do this
maybe that will help instad of trying to renew the old expired certificates


That won’t do anything useful.

You aren’t allowing access to the .well-known directory, so validation can’t work. You must allow access to .well-known. If you have any proxy rules or redirect rules setup for a web app, or whatever, they must exclude .well-known

Thanks Joe
Had to find a way to allow access and it
Worked fine…
You’re the BEST!
Thanks again

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.