SSL on subdomain, only shows one page.

Hi, i recently reinstalled debian on my server, and decided to install webmin/virtualmin so i won´t have to do all the setup myself (again). I have one problem, the server have one IP-address and is using one domain. I have set up two virtual servers as subdomains through the GUI.

This works perfectly. Now i wanted to enable SSL. So i enabled SSL on the top domain, added my certificate and key. and it works perfectly. The problem appears when i turn on SSL on the subdomains. Let´s say i enable SSL on and Now wether i try to open, or it will show the contents of dev.example, or the last vserv i enabled SSL for. I know this probably is a “side-effect” of SSL. But it worked when i set it up myself, and it was on the same top-domain. Do anyone know how to fix or work-around this?

If it’s a similar issue to what I had, I had to update one of the pages on each sub domain (or just reload the index file and save it). Not guaranteeing this will work for you but it did for me. My situation was slightly different in that my HTTP to HTTPS was not working. I could access the site via either, but it’s fixed now after that small load and save operation. You may want to give it a try.

I tried to reload all the index-files. Do a few reboots of the system usw. And it still dosen´t work the way it should.
Now some of the domains show the correct page and some don´t. Everything is still correct when using http. Right now it´s the top-domain that shows another page :frowning:


hi, it works same as on mine site. just create subserver enable ssl then click manage ssl and then go to lets encrypt and deploy it. see real working example from screenshot below. (subserver = subdomian = complete freedom to set ssl or features, just common name after dot)


I got it to work :slight_smile:

I just enabled SSL on all of the domains i wanted it to work on. Then i took one by one domain, and turned SSL of, and on. With the top-domain last. now it works perfectly XD

Unborn: I used a wildcard cert. That i only installed on the top-domain. Therefore I get a screen that says you can´t manage ssl on this server or something. Which obiously makes sense.


glad to hear you are sorted. I never use wildcard… prefer to manage ssl for each domains manually (best for troubleshooting) :slight_smile: