ssl not working for virtualmin management

hi there

i would like that each domain has it’s own login zone:, etc.

for each of this domains i have either self-signed or registered ssl certificates (wildcard). each running on a different ip.

with normal subdomains (for example roundcube on this solution works pretty nice. but unfortunately not for the webmin/virtualmin part.

as soon as i press copy to webmin this certificate is issued for all domains and overwrites all others, it’s somehow not per ip (as it would make sense).

any idea how i could make webmin available under a subdomain which then is covered with wildcard ssl?

otherwise i have to let all server user connect through one url, instead using their own accounts.

any ideas how to achieve this?



Well, most folks do indeed use one SSL certificate for their Virtualmin installation – and I suspect what’s happening is that chosing “Copy to Webmin” is always overwriting whatever SSL cert is currently installed there.

To use a setup such as that – you could also configure the Apache Website option in Server Templates to redirect admin.domain.tld to one specific URL, a URL where SSL is configured.

However, to do what you’re describing – while “Copy to Webmin” won’t work, you could always go into Webmin -> Webmin -> Webmin Configuration -> SSL Encryption -> Per-IP certificates, and configure your desired SSL certificates for each of the IP addresses on your server.


hi eric

thanks for the last input, i guess i have to check this out. but at the moment i have other huge issues, dkim is aparently not working anymore, well what’s going on these days…

maybe you can help me out there as well :slight_smile: