SSL issues


Yesterday I added a /28 ip address range to the server, created some CSRs and bought certs from godaddy. Installed one and spent hours getting httpd to run again. Eventually I deleted all SSL enabled sites and managed to get apache running, but no SSL and no webmail. Tonight I continued with getting it running. Same scenario when adding SSL enabled sites. apache fails, no error line reported, syntax checks ok, no errors in the logs (although I didn’;t go through all 100 site error logs) only the main /var/log/httpd/error_log one). Tried restarting with virtualmin and apachectl start. Again deleted all the SSL enabled sites except a default one (which has no certs) and have managed to get apache back running.

When I try to get it running with apachectl I sometimes get a screen error of unable to bind to port, already in use. A single httpd process was running. Killed that but unable to get apache running. Also a did a reboot with no effect on apache.

So for now port 80 and 10000 ok, 443 and 20000(webmail) fail. (other services all ok).

It is almost like without the cert files apache wont start.

Hunted and found:
But in my case I downloaded the certs as a zip file, mail/outlook wasn’t a factor. However did the modulus check and they are different. One thing was I had problems with pasting cert into virtualmin and not uploading so I scp’d the cert and ca up.

Any ideas? working with LAMP for +16 years in site hosting and have never seen this one.

Is the issue simply related to a certificate problem - and if so how to fix. If not any ideas?



Well, you may want to try adding just one SSL cert, and to troubleshoot that one until it’s up and running.

The procedure we recommend for setting up SSL is here:

If the modulus check is failing though, something is definitely awry.

If you haven’t already, give it a shot using the above steps, and see if that works better for you.


Hi Eric

Just reviewed that procedure and that is what was done. I just re-added the problem subdomain, and as per the procedure set to SSL etc. Then added a self signed key and so far ok. port 20000 for all users still fails.

fuser shows an active process owning the port (the miniserver) but no access from a browser down here in Hobart. Tried restarting usermin, no change.

So possibly the cert which the ssl page shows as a valid godaddy cert is the problem. Now to spend a while testing that.

However, any ideas now re the usermin. Could always go with roundcube, whats that like to install?



Once SSL in your Sub-Server is working – what happens if you go into Server Configuration -> Manage SS: Certificates, and then click “Copy To Usermin”.

After that, if you restart Usermin, are you then able to access port 20000?

Regarding RoundCube – that’s nice an easy to setup. All you have to do is go into “Install Scripts”, and from in there you can install it into your desired Virtual Server.


That works - you beauty.

Will try the roundcube now.

(Now to try and stop the duplicate emails that have been occurring on this new server).

Regards and many thanks

appreciate your time,