I was following the instructions on this page: to secure my webmin installation but I got the error SSL_ERROR_NO_CYPHER_OVERLAP when trying to access Webmin. there is another forum post that is similar to this ( but it did not fix my issue.

pls close this. i solved this

It would be of help to other users if you explained to us how you solved this.

I just managed to hose my virtualmin certificate by copying what turned out to be a broken domain cert to webmin in the web GUI and tried to fix in via ssh by doing:
virtualmin generate-cert --domain --self
virtualmin install-service-cert --domain --service webmin
/etc/init.d/webmin restart

which changed the initial error from (lost it exactly, something to do with key too long) to SSL_ERROR_NO_CYPHER_OVERLAP so trying to fix that. I tried the “comment out ssl_cipher_list line” from that post and restarted but no joy.

Any other clues @bhaberman?

In the end i managed to recreate my miniserv.pem from the public cert and key using similar commands to the instructions here

Hope that helps someone else, looks to me like the virtualmin generate-cert doesn’t create valid certs :frowning: