SSL Certificate works on one port but no on other

OS type and version Ubuntu Linux 20.04.6
Virtualmin version 7.5

SSL on website port 10000: works like a charm.
But SSL on the same website but on different port 443: does not work.


How to fix guide me, please.

Can you send me a screenshot of your “Configure SSL website” and your current certificate.

Kind Regards,

New one, ssl looks good on port 10000.
The normally the common name should be the domain, not a subdomain. Did you name the server
Still not sure why the website is not working though. Do you see any usefull info in your log files,



yes name of my server is:
and also my hostname is the same:

This is my dashboard:

you have alot ticked there, did you do that?

Yes i ticked all protocol, inorder to make the site working. But no change

I’ve never had a issue. What did you add in your Lets Encrypt tab. Only other thing I can think is the location of the cirtificates. Can you see if they are there?

Yes certificates are present that’s why its working on port 10000

Yeah very strange issue idk how to solve

There is not much to chnage in lets encrypt tab. I have shared you details of server over private chat check it your port 80 doesn’t seem to be going to virtualmin

Http port 80 works fine. Its not 90 is 80

Port 80 goes to apache and port 10000 goes to virtualmin

All port works fine except 443, how to resolve?

I’m willing to bet one is IPv4 and the other is IPv6. The one that isn’t working will probably be IPv6.

Check that out and see if I’m right.

Ipv6 is disabled. Its all ipv4

But did you check the port assignments?

If it’s assigned to IPv6 and you’ve disabled IPv6 then guess what?

Run ‘sudo netstat -ntlp’ and see what port is on what IPv.


Based on your IP address assigned to the domain, it looks like you’re behind a residential Internet connection.

Have you setup port forwarding to your system?

I’ve attempted:


no reply

telnet 80

connection timed out

telnet 443

connection timed out

telnet 25

connection timed out

telnet 10000

connection timed out

There appears to be an issue connecting to your system.

*** On a segway, you should rename the “host” of your system to something like “” instead of using the naked domain “” ***

I ran:

dig ns

no NS records assigned

dig a

no A record for “

dig a

no A record for “

*** you’ve got DNS issues too ***

There appears to be a lot of issues with the setup ATM.

1 Like