SSL Certificate server name issues


I installed Virtualmin GPL on a new server, and as part of the process generated a self signed certificate which all worked swimmingly. However, I got the “this server cannot be trusted because of a self-signed certificate” warning each time I went to the Virtualmin interface.

To solve this, I rushed out an bought my very first SSL certificate ever, from RapidSSL. I followed all the instructions I could find on Google, etc, and I think the certificate is installed properly, but I still have a problem. When I go to the url, I get “You attempted to reach, but instead you actually reached a server identifying itself as * “ (in Chrome).

Clearly, somewhere, somehow something is being redirected to * when I want to go to (or 20000).

I have checked on and that shows that is hunky dory. There only seems to be an issue when port 10000 or 20000 is involved.

I would really appreciate any suggestions as to how to get rid of the pesky “*”.



Looking at the certificate information displayed when I click on the padlock in Chrome, it seems that Virtualmin is still using the self-signed certificate.

How can I change that?

I had to copy the cert to Usermin and Webmin.

Hi NettSite,

because i have the same problem,

and i also baught a RapidSSL, in VirtualMin
i see that the Issuer Organazation is Geotrust ,
but when i try to see my site with https
i see that it is still self-certifated.

In Webmin how can i install the same SSL
because when i tried to copy the Private Key and Certificate
i took back “Missing or invalid PEM format key and certificate”

what is the correct process?


Hi sarantisf,

My server is, so I created a virtual server called and installed the certificate there.

Once it is installed, on the page (Manage SSL Certificate) there are buttons to “Copy to Webmin” and “Copy to Usermin”. Just click those and it all works!