SSL Certificate Issues with Public IP Name

OS type and version Centos 7
Webmin version 2.001
Virtualmin version 7.3
Related packages SUGGESTED

After having some trouble reinstalling Virtualmin (I installed it successfully but then uninstalled it), I started from scratch wiping my VPS and installing Virtualmin. The installation seemed to go okay. However, I am not able to access Virtualmin from because the browser complains about a certificate issue. I can access Virtualmin using its internal address.

When I look at the SSL certificate in Virtualmin it says this:
SSL certificate file /etc/ssl/virtualmin//ssl.cert
SSL private key file /etc/ssl/virtualmin//ssl.key
Web server hostname * Organization Host default domain
Issuer name * Issuer organization Host default domain
Expiry date Nov 16 19:11:32 2027 GMT Certificate type Self-signed
Other domain names *, localhost, **Used by services Webmin (, Webmin (global), Usermin (host, Usermin (global), Dovecot (host, Dovecot (global), Postfix (global)
Download certificate

Download private key

Time until expiry 1824 days until expiry

I noticed on another machine that is running Virtualmin properly that the issuer of its certificate is Let’s Encrypt.

The error I get when I attempt to access is:

Did Not Connect: Potential Security Issue

Firefox detected a potential security threat and did not continue to because this website requires a secure connection. has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

Thanks for everyone’s support as I try to get this machine up and running. You can be sure I am learning a lot about what to do and what not to do so again I thank you for your patience and help.

Try using a private window in firefox and see if that allows a exception.

It does!

Does that offer a clue as to what is going on?

What you mean with the browser or you certificate? Only thing I can think with browser is firefox have added extra security. With the certificate, go into the SSL settings and Lets Encrypt tab and request a new certificate.

The browser works with the certificate. It warns me there is a security issue but let’s me move forward recognizing the risks. The standard browser won’t let me proceed as noted in the output above.

I requested the Let’s Encrypt certificate from the private browser and it worked. Let’s Encrypt was complaining when I was requesting the certificate through the standard browser. Public access is now available.

Thank you!

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.