SSL certificate installed fine, now the IP address?

Hi guys, I wanted to check in quickly on how to assign a newly added private IP to an exisiting virtual server for the purposes of using and SSL certificate - although it must be said that the shared IP address is working just fine anyway.

I added the new IP address as a virtual interface in webmin > networking interfaces

The virtual server is ready for SSL, the certificate all works so installed correctly - now what do I need to change for the IP? I previously tested it and it knocked the dns back for a few hours so I am quite sensibly taking it steady now instead and double checking.

I assume adding the changed IP does not affect the bind settings or edits them as required or do I need to change it all manually.


Hi guys, any chance of some guidance on this please.

I have followed the instructions and it would seem the easy way to achieve this is to go into server configuration and choose add private ip address then input the ip address in the text box, however the text box is nowhere tobe seen.

I have read other posts that experienced the same problem. I have created the virtual interface already but cannot assign the ip for my clients SSL certificate


If you have a new IP address that you’d like to assign to a domain, you can do that by going into Server Configuration -> Change IP Address, and in there, you can set a new Private IP.


Hi Eric. I have done that again and been met with a different problem this time

So to go over it again;

I go to
webmin > networking > network configuration

network interfaces > eth0 > add virtual interface using the private IP

after this I go to
virtualmin > select virtual server from dropdown > server configuration > change ip address

allocate private address tickbox - on this occasion is does allocate a private IP address but for some strange reason it creates one using the old IP address settings of the server and not the current one so rather than for example

I had to move the IP address following a constant DDoS, the server settings all reflect the new IP address so where is it creating a new virtual interface using the old IP?

I can see during this process that there was no need to create the virtual interface beforehand and it will do this for me, however for it to work I need to have the virtual interface created from the right IP address for obvious reasons

Hi guys, I just went over my network settings and indeed everything is still showing as the correct (new) IP address, however when I test the allocate new private address I am definitely getting the old IP being pulled through on creation:

Adding virtual IP interface for …
… created interface eth0:3

That should be my new IP address - where is this IP address being taken from if I have changed everything over to the new IP, I guess there is a config that has not replaced the old 188 address correctly.


Hi Eric, just checking in again to see if there is any advice you can give. I cannot get virtualmin to create the private ip address correctly, it always creates using the old server IP and not the one in any of the networking configs that I know of…

many thanks


Well, when adding a new IP address, you don’t actually need to go into Webmin first to setup the network interface.

When you go into Server Configuration -> Change IP Address, and input your IP address, it’ll actually setup a new network interface for you by default.

However, if you already did setup a network interface – after inputting your IP address to use on the Change IP Address screen, you’d need to make sure you check the “Already active” checkbox.


Hi Eric, as you say when I switched the server to the new IP I just used the change IP function as documented elsewhere and as above I added the new IP using Webmin but realised afterwards that the change IP address function in Server Configuration it does this for you.

My issue is with neither of these though.

My server IP for example is

It used to be

Every config has the new IP address listed correctly, all DNS records have the new IP address correctly but if I go into a Virtual Server and use: Server Configuration -> Change IP Address > it creates the new Virtual Interface using the old IP address and not the new one.

I can edit the new virtual interface of course but the bigger concern is that all of the DNS records are created using the old IP which makes it a problem.

Any ideas where this create a new Virtual Interface function would be pulling the OLD IP address from and not the one that the server and live websites are actively using? It could be a bug of course but I wanted to exhaust your knowledge before I submitted a report.


Ok, another update for the night. I am getting fed up with this now as I posted this thread up on the 14th April and it is still not right…

Now though, after a night of messing with my networking configs to make absolutely sure that they are all showing the right IP address for my server I am unable to access virtualmin either via the URL or IP address, I can still get on using SSH but cannot access the control panel.

Something as simple as adding a new IP address for an SSL certificate has taken weeks, clearly there is an issue somewhere with either a rogue config file somewhere or my virtualmin in general but the fact still remains that despite my server not using the IP (made up) anywhere it still creates a new virtual interface for this IP address as well as all the DNS records to match - this is NOT correct.

I understand that you’re frustrated, I know it sucks when things don’t work right!

This is a fairly common thing that folks do, and we haven’t had any other reported bugs in this area – so I’m wondering if there may just be a button or something along the way that’s not being clicked.

When you change the IP address, and if you click the “Already active” button, it should always use exactly the IP address you entered.

It shouldn’t be using any IP’s from config files you have, it should be using the IP as you enter it there. In theory :slight_smile:

Here’s what I would try –

First, run the command “/sbin/ifconfig” – what output do you get?

Then, go into Server Configuration -> Change IP address, and let’s step through each little part of that just to make super sure that all these parts are correct –

  • Click the radio button next to “Use private address”

  • Then enter the IP address next to “Use private address”

  • Click the “Already Active” checkbox

Before doing anything else, can you take a screenshot of that screen? I’m curious how all that looks.

Then, click “Change Now”. Can you paste in any output that you receive while clicking that button?


As far as not being able to access Virtualmin – that may be a different problem, but the first thing I’d do there is try to restart Webmin, which you can do with this command:

/etc/init.d/webmin restart

After that, do you continue to have the same problem?

If so, what error do you get when trying to access it?

And does the same problem occur when trying to access it via the IP Address?

Lastly – is this a dedicated server, or VPS? And if a VPS, do you know what kind of VPS it is?


Eric, the output of ifconfig is:

eth0 Link encap:Ethernet HWaddr 02:00:00:29:f6:4e
inet addr: Bcast: Mask:
inet6 addr: fe80::ff:fe29:f64e/64 Scope:Link
RX packets:581516 errors:0 dropped:0 overruns:0 frame:0
TX packets:592486 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:113070018 (113.0 MB) TX bytes:265877400 (265.8 MB)
Interrupt:20 Memory:df5e0000-df600000

eth0:1 Link encap:Ethernet HWaddr 02:00:00:29:f6:4e
inet addr: Bcast: Mask:
Interrupt:20 Memory:df5e0000-df600000

eth0:2 Link encap:Ethernet HWaddr 02:00:00:29:f6:4e
inet addr: Bcast: Mask:
Interrupt:20 Memory:df5e0000-df600000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:1378382 errors:0 dropped:0 overruns:0 frame:0
TX packets:1378382 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:104886359 (104.8 MB) TX bytes:104886359 (104.8 MB)
no mention of the old IP address anywhere.

Ok on to the next stage of adding a new IP:

Click the radio button next to “Use private address”

Then enter the IP address next to “Use private address”
There is nowhere to enter an IP address, no text box, no dropdown box - all I can do at this stage is click save. This in itself would not be a problem but Virtualmin keeps creating a virtual interface automatically using IP details that are not in use on the server at all which is the reason for my frustration - even if this is a quirk it would still perform brilliantly if only it would use the correct, current IP address.

Click the “Already Active” checkbox

I cant screenshot this at the moment as I am also now unable to access virtualmin control panel as a side effect of my trying to find why this issue has arisen.

**** added, I just realised that the IP area you are mentioning applies in my case to ipv6 only - I do not use ipv6 currently and am trying to do this using the ipv4 section

restart Webmin, which you can do with this command:

/etc/init.d/webmin restart

It restarts just fine - still no access to the control panel though

After that, do you continue to have the same problem?

Yes, I cannot access either by the URL or directly using the IP address.

If so, what error do you get when trying to access it?

This web page is not available
Google Chrome could not load the web page because took too long to respond.

Same issue in other browsers.

****Added **** I just disabled ufw and I now have control panel access, the strange thing is that 10000 and 20000 ports are allowed already so i am not entirely sure where it is being blocked ****

Obviously right now I am in a bind, while the virtual servers are up and running it is not critical but in no way shape or form should adding a private ip address be this tricky - on the 17th May I had pointed out that the tickbox for use private IP is there but no where to put an IP as per the instructions.

I do understand that the GPL version gets support on the forum and users like myself need to be patient which is fair enough but on a few occasions through this thread I have detailed everything in a step by step format and end up having to repeat the same thing each day.

Finally, this is a dedicated server running Ubuntu 12.04



I again understand that you’re frustrated. I’m doing my best to assist :slight_smile:

I know that some of what I asked above, you’ve previously done before… that’s why I was asking for a screenshot this time, I want to see what you’re seeing :slight_smile:

The process of adding an IP address is normally quite simple and straight forward, and the behavior you’re describing is unusual. I’m hoping to get a better understanding of what’s going on.

You described that there isn’t a field for an IPv4 address. Once a private IP address is set, you’d need to convert back to a shared IP before you can switch to another private IP.

Also, one other thing you may want to check… in System Settings -> Server Templates -> Default -> Virtual IP Address, do you have any ranges setup?


Hi Eric, first of all I will apologise if it seems my frustration is aimed toward you - it is not, just purely frustration on my part now.

The situation now is that the virtual server in question is using a shared IP, the same one in use by the rest of the clients on the server so from that perspective we can treat this as starting from fresh.

So, on to your suggestion. You appear to have answered the question in it’s entirety. The System Settings -> Server Templates -> Default -> Virtual IP Address had indeed got my OLD IP range. I have removed these IP’s and now when I go into change IP address there is a checkbox available for the IPv4 tickbox.

I have tested this on an inactive site and it would appear that the IP change works as I had first hoped, along with the DNS records - perhaps it it worth adding a line to the documentation about this to save anyone else head scratching.

In any case, many thanks. I can finally get my client moved to his dedicated IP address.



That’s great that you got it working!

That’s a good idea, I’ll talk to Jamie about adding a note to the Change IP Address screen to identify that it’s pulling in an IP address from the Virtual IP Address section, or at least mention it in the documentation.

Have a good weekend!