SSL Certificate and phpMyAdmin

I have a Centos 5.2 server and yesterday I bought a SSL cert from Godaddy and installed it based on some instructions on this forum. It worked fine… no issues. However today I noticed that when I go to http://localhost/phpmyadmin or https://localhost/phpmyadmin I get a 404 error. I think is due to the SSL I added, since it was working before I did that. Can you point me in the right direction for troubleshooting? I appreciate it. My phpmyadmin install resides in /var/www/html<br><br>Post edited by: webscout, at: 2009/02/18 09:31

The easiest way to do what you’re after would be to setup a Virtual Server, and install phpMyAdmin within that given Virtual Server.

That would also give you the ability to take advantage of your new SSL certificate – you could move the phpmyadmin install into the DocumentRoot for your newly setup SSL cert, and use it together with that.

If all that doesn’t interest you, I’m guessing that it worked before because going to “localhost” was taking you to the default VirtualHost – and that today, the default VirtualHost is different. You may just need to re-order the VirtualHosts such that the one you want to pop up when someone types in “localhost” shows up first in the httpd.conf file.

Thank you! That got the wheels turning.

I used this command to fix it.

ln -s /var/www/html/phpmyadmin /home/mydomain/public_html/