SSL Cert expired for Proftpd, cannot assign new cert via virtualmin

SYSTEM INFORMATION
Rocky Linux 9.4 REQUIRED
Virtualmin version 7.10.0 REQUIRED

The ssl certificate expired only for proftpd, everything else got renewed automatically. When I checked my proftpd config file the ssl certificate paths where different to those of the other services I have running. I have updated my config file to use the same path as the other services and it now works as it should and does not show certificate expired messages upon connecting.

My question is how can I manage this from webmin/virtualmin, I can configure proftpd from webmin but I cannot push an ssl cert to it using virtualmin.


Proftpd doesn’t even show under used services. Is there a way to fix this and manage the proftpd ssl cert the same way I can everything else without having to manual update the path each time I need to request a new certificate?

Thanks for looking.


Proftpd works as it should but it doesn’t show status in the above screenshot on virtualmin dashboard. Anyone know how I can fix this?

It shows under webmin tab and Servers and I can edit config from there.
proftpd2

@Jamie, is there an actual reason why ProFTPd doesn’t show up among the list of service certificates on the SSL Certificate page?

It will only show up in the “Used by services” list if Virtualmin detects that the cert is shared with the domain.

If you want to configure ProFTPd to use the domain’s cert, you can either do it on the SSL Certificate page, or with the command :

virtualmin install-service-cert --domain whatever.com --service proftpd --add-global

How to do it using SSL Certificate page?

1 Like

Running the command using CLI I get this:

root@debian12-gpl:~# virtualmin install-service-cert --domain debian12-gpl.virtualmin.dev --service proftpd --add-global
Invalid service proftpd. Valid services are dovecot usermin webmin postfix mysql

Perhaps the detection for ProFTPd fails?

1 Like

I just tried your suggestion and it gives me this error:

Invalid service proftpd. Valid services are dovecot mysql postfix usermin webmin

Oh I think I see the bug. Make sure that at System Settings → Features and Plugins that the “ProFTPD virtual FTP” feature is enabled.

Everywhere else says not to enable this feature but it does indeed fix my issue.

Yeah I’m thinking we should de-couple that feature from whether an SSL cert can be assigned to ProFTPd.

1 Like

Yeah, there’s never a reason to enable IP-based Virtual FTP today. ProFTPd has supported SNI for years, and it should be available on any OS supported by Virtualmin now, I think.

We do support SNI-based virtual FTP for proftpd now as well. That said, I feel like per-domain virtual anonymous FTP sites are rarely used these days. So we shouldn’t couple that feature in Virtualmin with being able to add an SSL cert for FTP. I’ll look into this for a future release …

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.