SSH backup

I just found out when a backup is uploaded via ssh to a remote site it doesn’t overwrite the old files. I just attempted a restore and the file is from 2 months ago when I set it up. The log says it’s been backing up. Is this normal? How do I setup the backup to overwrite the old file each night?


It should definitely overwrite old backups.

There are two things I’d check –

First, is there anything about the permissions of those files that might prevent the backup process from overwriting them?

Second, you may want to verify the server and path the backups are being sent to, just to make sure they’re being sent where you expect them to go.


Permissions look ok. I actually moved the old files and left the destination backup directory empty. Manually scp’d a file over and it worked. Tried the virtualmin backup and although it reported no error it didn’t scp the files over. :frowning:

That’s an unusual problem.

One thing you might try is to scp a file manually, using the username and backup directory that’s configured in the Virtualmin backup screen, and see if you run into any errors while doing that.

Also, on the backup screen in the “Schedule and reporting” screen, make sure your email address is listed in “Email backup report to” so that it knows who to deliver a report to if things go wrong.


I deleted the backup and started from scratch. Now it seems to work. The odd thing is looks and acts the same.